35

Since Yosemite, the green button in the upper left corner on each window activates the fullscreen mode. By holding alt, it works as before (Mavericks). Is there any possibility (Terminal?) to change this behaviour back to "normal"? For example: holding alt for fullscreen mode?

Update

You can change the behaviour back to "normal" with BetterTouchTool.

  • 2
    Really hope changing it back is possible, inadvertently hitting fullscreen mode is super annoying. – jerwood Oct 21 '14 at 8:11
  • 2
    Duplicate of: apple.stackexchange.com/questions/151734/… – k0pernikus Oct 21 '14 at 9:32
  • 1
    Noting that the other question does indeed seem to cover the same functionality, but it is muddier. This one quite precisely covers my exact question. – funroll Nov 7 '14 at 15:48
  • @Slevin Did you solve your problem ? – StrawHara Oct 7 '15 at 14:37
10

Hold down Option key and click the Green button. It will change from the Full Screen button back to a Zoom button.

You can also double-click the empty area in the window frame (title bar) if you don’t have it set to minimize when double-clicking.

However, this soft can help you : https://www.macupdate.com/app/mac/30591/right-zoom

Apple Support

  • 8
    The OP knows about Option/Alt way. He asks how to revert it to "normal" (the way it worked on Mavericks) - maximize without pressing additional key. – Mateusz Szlosek Oct 21 '14 at 9:06
  • I think that is the only solution. You can't update to Yosemite and change everything because it's not the same than Mavericks or Leopard... There are no sense. – StrawHara Oct 21 '14 at 9:10
  • 2
    I agree with @MateuszSzlosek. Besides, the software you suggested does not even solve the OP's problem. You could look at the discussion/feedback in the webpage you linked. – Leo Fang Oct 22 '14 at 6:36
  • +1 for this tip "double-click the empty area in the window frame (title bar)". Would still like to see a way to reverse the zoom button behavior. (So Option + Click goes to full screen.) – funroll Nov 7 '14 at 15:52
  • 1
    Double clicking menu bar in chrome doesn't maximise it – Claire Nov 13 '14 at 14:09
4

According to what I could find, you cannot change the default behaviour (much like most things in OSX) ... however what I ended up doing is using a keyboard shortcut to use zoom. The following answer helped me do that: https://superuser.com/a/718843/98807

Essentially:

  • System Preferences -> Keyboard -> Shortcuts
  • Add a custom "App Shortcut"
  • name "Zoom"
  • whatever key combo you want e.g. Opt+Cmd+=
4

Double-clicking the empty area in the window frame (title bar) seems like the best answer. In fact a great one, since this is a larger area than the green button..

Worth noting that Firefox wants to hide the title bar – this threw me for a while. Go to 'toolbars>customize' and click on 'title bar' to get it back.

2

I use alt + shift + the green button. This reflects the Windows maximize button behaviour.

1

According to this page you can achieve this using BetterTouchTool

  1. Download BetterTouchTool here
  2. Open BetterTouchTool and grant access to “Accessibility” when requested (this will open System Preferences > Security > Privacy > Accessibility)
  3. Allow BetterTouchTool access in OS X Preferences
  4. Back in BetterTouchTool, click on the “Other” tab in the upper right of the app
  5. Select “Global” from the left side options
  6. Near the bottom, click on “Configure New Trigger”
  7. In the “Trigger” pulldown menu, choose “Leftclick Green Window Button”
  8. In the “Predefined Action” menu, choose “Zoom Window Below Cursor”
  9. Flip back to the OS X Finder (or another open app) and click the green button, it should now simply maximize the window rather than send it into Full Screen Mode (even if the icon changes to fullscreen when the mouse hovers).
  10. Close BetterTouchTool preferences pane (Red Window Button)

The changes will stay in effect as long as you have BetterTouchTool runs in background (its icon should appear in the menu bar, and that it is configured this way.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .