2

I've just upgraded from mavericks to yosemite, the download was sluggish but eventually worked so I don't think any of the files were corrupted. There was no hitch with the installation as far as I know either. All I know is that when I woke up after leaving my MacBook Pro (15 inch, mid-2010) its fan was spinning out of control at the login screen.

When I restarted and looked at the activity monitor I saw that core audio and launchd were the culprits. I've tried the following to fix my problem:

  • Clearing the PRAM.
  • Clearing the SMC.
  • Deleting the plist for the audio preference pane.
  • Verifying disk permissions.
  • Repairing disk permissions.

Additional info: I've run etreCheck a few times and have fixed most of the things it pointed out, all that is left is:

System launch daemons with problems : [fail] com.apple.systemstatsd.plist

Launch daemons with problems : [invalid?] com.adobe.SwitchBoard.plist Aide

I've searched and haven't found any answers that worked yet. Anything else I can do apart from a reinstall?

Also I've noticed that bluetooth can't be turned off anymore although it doesn't actually seem to be on, any fixes for that would be appreciated too.

  • since as you say there were many install hick-ups how about cmd-r to restore it. – Ruskes Oct 21 '14 at 6:13
2

Just had the exact same issue after restarting. I had previously unloaded a bunch of services.

The bluetooth issue was due to unloading the bluetooth service, but I had a bluetooth mouse plugged in via USB, I guess there was some override in the IO or something.

Loading the service again fixed the issue.

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.blued.plist

The core audio issue seems to have been fixed by loading the video assistant again

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.cmio.IIDCVideoAssistant.plist

Hope this helps someone as there shouldn't be the need for a full system restore because of one or two service issues.

  • This solved it for me, greatly appreciated! – Dominik Antal May 27 '15 at 7:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .