108

After a clean install of Yosemite, multi-touch gestures have stopped working on two occasions on my Macbook Pro 2011. Each time, the symptoms are the same:

  • Gestures stopped working both built-in trackpad and bluetooth trackpad.

  • BetterTouchTool still works. Restarting, stopping BTT doesn't help.

  • Hey, at least two-finger click -> right click still works.

I've tried the following:

  • Toggling trackpad configurations doesn't bring back the gestures.

  • Disconnecting, reconnecting, removing bluetooth trackpad from list of bluetooth devices doesn't work.

Restarting solves the problem. However, a restart in my case is a time-consuming process. It involves properly shutting down apps, dismounting network storage, disconnecting VPN, etc - only to revert all the steps again on startup.

I suspect the process interpreting multi-touch crashed when the malfunction happened. CPU was quite busy at both point. So I wonder if there is a process I can call up when it happens again, to avoid restarting the machine.

  • 4
    I think Trey needs his answer credit. – Brian Fegter Jan 26 '17 at 3:48
199

Type killall Dock in Terminal.

In my case, only Mission Control gestures had stopped working (three finger swipe left/right to switch spaces, three finger swipe up for overview, mission control etc).

  • When this happens to me it's not Mission Control gestures that stop working, it's Mission Control—keyboard shortcuts also fail. – samh Feb 6 '16 at 11:53
  • 5
    Note: you may use activity monitor to kill dock if terminal is blocked – micsthepick Oct 29 '17 at 9:02
20

By my experience, multi-touch crashes on a per-app basis. I could quit the app and relaunch it, and gestures would be back.

Apparently, sleeping the display and then waking up the system again will bring back crippled gesture. You can click button to do that, or just close the lid, or use terminal:

pmset displaysleepnow; sleep 5; caffeinate -u -t 1

After one second of black screen, gestures are back.

(P.S.: I'm answering my question here, so if it works for you, upvote and I will mark it as accepted)

  • I was periodically losing two finger swipe in firefox. This answer restores functionality. – AGS Mar 30 '16 at 11:08
  • Another upvote from me. This still works in 2018, on OSX High Sierra (10.13). I was having issues with my magic trackpad after I unplugged the charger from it. I put the display to sleep, left it for a few seconds, then woke it up and my gestures work again! Thank you. – Someguy123 Nov 24 '18 at 7:49
14

Hit the same issue. Found this old thread, where user frimp advises to press power button and let MBP sleep for a while, some 5-10 seconds is enough. Then wake it up — gestures are back.
Further search shows this issue is quite old, at least since mid 2012.

Though I would really like to get this fixed permanently…

  • This worked for me. SomeDude's answer (disable/enable all scroll and zoom gestures) did not. – Jess Riedel Jun 13 '15 at 12:21
5

I found a faster solution. In settings → trackpad, disable all scroll and zoom gestures, then reenable them. The trackpad should start working again almost immediately (at least it did when I tried it).

5

Sleep is useful, however, not always preferred for me as I have some tasks running, listening to music or whatever may be.

Killing the dock or the apps haven't worked, unfortunately.

I have found that with Sierra I am able to get the swiping back with force quitting hidd (Human Interface Device Deamon) multiple times (restarts automatically).

Edit:

After finding out about this AskDifferent answer I was able to narrow down the issue to Magnet. Quitting its process, I have not had the issue repeat in 2 hours.

  • Killed Magnet, I hope this is indeed the cause, this issue is a huge pain right now. Thanks for sharing! – GuiSim Jun 20 at 19:57
  • @GuiSim recommend moving to Moom. I have also had a repeat of the same problem with Better Touch Tool. They are both disabled for me. I haven't had the problem since. – arin Jun 20 at 21:01
2

killall Dock did not work for me.

pmset displaysleepnow; sleep 5; caffeinate -u -t 1 did not work for me.

sudo killall hidd did work for me on OSX 10.13.6 (17G4015).

  • Worked for me also on 10.14.5. Instant improvement. Bizarre. – John Smith Jun 15 at 2:48
1

I'm having the same issue periodically only since upgrading to Yosemite (I did not do a clean install.) For me it has been affecting only 4 finger swipes (all 4 directions are completely unrecognized) on both the built-in trackpad and on a BT magic trackpad.

Interestingly, the problem went away for me (at least for the moment) without a reboot after I killed a process that was misbehaving. I saw errors in the console once per second with the following text: assertion failed: 14A389: libxpc.dylib + 40320 For me these messages are attributed to the Spokes app (a Plantronics helper application for my headset), though I have seen it reported for other different applications on Yosemite as well.

It may be anecdotal that the gestures started working again after I killed the offending app, but I'll watch to see if there's a correlation in the future, since this problem has come and gone a few times since my upgrade and it's not my first time killing this app nor my first time with gestures resuming without a reboot.

1

One trick which I learnt about from a similar problem here using Steam.

Create a copy of the "BetterTouchTool.app" and call it something like "BetterTouchTool2.app". When it stops working, just open "BetterTouchTool2.app". This should allow you to continue using it without a restart.

You must log in to answer this question.

protected by Community May 3 at 12:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .