10

Right now I can't seem to send some text messages from my OS X. Here is a list of things I have done that will have caused the error:

  • I fresh installed Yosemite about 2 days ago
  • I updated my iPhone to 8.1 this afternoon
  • I paired my device (I was able to send some texts from OS X)
  • I fresh installed iOS 8.1 on my iPhone
  • I can't send some text messages from my computer

When I start a new conversation on iMessage, the name of the person remains red. When I try to send a message I get a popup saying: " is not registered with iMessage". The handoff is well configured because I am able to see an icon appear in the dock when I use the notes app.

What can I do to make this functionality work again?

Thanks

13

You need to wait for the iOS 8.1 update in order to be able to do SMS from your computer / iPad. It should be available for you now or tomorrow if you go to "settings -> general -> software update"

EDIT: "iPhone Settings -> Messages -> Text Message Forwarding" then select your device that you want to send from and enable it :)

Restart messages on OSX if it's still not working.

  • "I updated my iPhone to 8.1 this afternoon" – Philibobby Oct 21 '14 at 0:33
  • Just saw that. It's probably just a software glitch then. Possibly try waiting for a few days to see if any other reports spring up or an update drops for it. – Thought Space Designs Oct 21 '14 at 0:34
  • It is just sad because I can't use the functionality :( Thanks for the answer – Philibobby Oct 21 '14 at 0:36
  • 1
    See my updated response. It's under your settings. – Thought Space Designs Oct 21 '14 at 0:57
  • I do seem to still be having issues with it syncing with my Mac, however. It just seems wonky at this point in time. – Thought Space Designs Oct 21 '14 at 0:59
4

Also check the OS X settings: Messages > Preferences > Accounts.

In my case the Messages app had disabled my AppleID account and enabled a new Google Jabber account.

  • I just ran into this after changing Apple passwords. – Michael Stern Jul 5 '16 at 15:43
1

I had this issue, but quitting iMessage and relaunching iMessage fixed it.

1

The contact you are trying to text via iMessage needs to re-enable (or re-register) iMessage on their freshly updated iPhone. This happened to my wife and I.

The contact in question needs to go to Settings --> Messages and move the slider to enable iMessage:

enter image description here

1

I just had this problem, and I figured it out! I tried all of the above solutions, but to no avail. Both my computer and phone are updated with the latest versions of software. Anyways, you should check your iPhone messages section (in the Settings app), where it says "Text Message Forwarding." Make sure the slider is slid to green for it to allow messaging from computer or iPad, then your texts will send fine to everyone. I just sent a few messages to people that I couldn't access a few minutes ago. Hopefully this helps someone out there!

  • the code that generates on my computer. But where is it? i can't find. Please help me. – user106385 Dec 28 '14 at 6:30
-1

Make sure you type the number in the right format. For the US, type +1XXXYYYZZZZ (XXX=Area Code, YYY=Prefix, ZZZZ=Suffix).

-3

You have to use your friends email that's registered as their Apple account.

You must log in to answer this question.

protected by Community Jan 7 '15 at 23:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .