I have a 1 TB USB drive.

I've been using it for months.

My main iTunes library is on it.

As of yesterday, for no apparent reason, it has become read only.

I can't open iTunes.

enter image description here

I also tried this...

enter image description here

Here is the info panel on the drive:

enter image description here

Note that the format is currently "Mac OS Extended Case-sensitive."

"Ignore ownership of this volume" is checked, but greyed-out.

Backing it up and reformatting is not practical due to the sheer amount of data.

How did the volume become effectively read-only?

Any suggestions for how I can get use of the drive back?


Who's "Fetching..." ?

I looks like it can't grab the correct perms/ACL. Have you tried setting up the perms again?
My guess is 'fetching' ought to be the _myname account, which my less than stunning grasp of nix perms leads me to believe is the system process working in your name.

ie it's lost the permission to work on your behalf.

At minimum, I'd guess setting everybody to read/write would at least be a workaround - as there's no ownership, how does it know it's working on your behalf or anyone else's?

[Someone with a better grasp of nix perms please comment/correct/append to this]

  • fetching... should be the group membership of the owner of the drive (greyed out (me)). – klanomath Oct 21 '14 at 7:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .