60

This question already has an answer here:

iPhoto starts launching when iPhone is connected even though it never used to before Yosemite. Steps described in: On connecting device - iTunes or iPhotos must not open does not work in Yosemite. Yosemite seems to ignore the iPhoto settings.

marked as duplicate by bmike Oct 27 '14 at 12:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

113

With iPhone plugged in.

  1. Open application "Image capture"
  2. Select your iPhone
  3. Press the triangle in square symbol in the lower left corner.
  4. Choose "No application" in the droplist under "Connecting this iPhone opens:"

Screen dump for clarification

  • 4
    If this is the answer, your question was an exact duplicate. – Rob Oct 21 '14 at 9:30
  • I would have preferred to see this answer on the other question, as it provides details when you're looking for the option in Image Capture rather than in iPhoto. – Joost Oct 21 '14 at 15:04
  • Well @Joost. This solves the problem of iPhoto opening. The answer did not lie in iPhoto. The settings in iPhoto are ignored. The question is answered. iPhoto no longer opens. – GusOst Oct 22 '14 at 10:03
  • 9
    @Rob no it's not! The iPhoto settings are ignored! Changing in Image Capture is not exactly the same as changing in iPhoto. It's similar. But it doesn't work in Yosemite. Why do people without this problem bother to say it does not work when it does? Or say it's the same, when it's not. – GusOst Oct 22 '14 at 10:03
  • 1
    The image used by Yosemite looks like an "eject" image, which threw me. This is in fact the same /kind/ of thing we had to do in previous OSs, but then, merely selecting the device offered the same sub menu. Now you have to click a button that looks like it will unmount the device. – Tim D Dec 22 '14 at 14:30

Not the answer you're looking for? Browse other questions tagged .