My MacBook Air mid-2012 model running OS X Yosemite logs off automatically without any prior warning when I am working on it. This has been happening since the latest update, to Yosemite.

The logs from the moment of logout are here:

To be more specific my Air has been connected to an external monitor both times and has been charging both times too!

Similar problems have been discussed on Apple Support Communities:

  • I have the same problem with my 2012 Retina MBP. It has happened with and without my external displays connected. – Blake Oct 31 '14 at 14:00
  • Yep, it happens to me also once every other day. Thought in the begging I thought it was matter of the system being overloaded (I tend to open sometimes too much Chrome tabs and programs), but it happened lately just with very few programs. – chodorowicz Nov 14 '14 at 8:02
  • same problem here, same log from chrome too (I got here by finding your pastebin then googling for that to find this post) – Aaron Jensen Dec 6 '14 at 6:42

I have the same problem with a MacBook Pro Retina and since Yosemite.

I was able to track down the corresponding crash, at each occurance of the "log off" there is a WindowServer crash log generated. After goolging I've found this post in the Apple forums:


Summary of the post (detailed instructions are in the post)

The bug could be due to a memory leak in the video memory. Users with external monitor are much more susceptible to have the bug. Because it crashes the WindowServer, all connected users are logged out, but sometimes some of their process still remain running.

  1. Unplug all external monitor;
  2. Fix filesystem permissions using the Safe Mode;
  3. Reset the Mac SMC, and allow for a full start and shutdown afterwards;
  4. Reset the NVRAM (also called PRAM previously).

I've done these steps, and I cannot be sure that it solve the problem. These random logout occured not every day, and sometimes multiple times in the same day. But since I applied them (this morning) they do not occur anylonger, but that's still a bit short to be sure.

Anyway worth a try!!

  • The problem persists after completing all of those steps, unfortunately :( – Blake Jan 13 '15 at 17:13
  • Since I completed those steps I only had once a crash (2 days ago). So it is not a complete fix which hopefully will be provided in a coming updates by Apple, or at least I hope. – Huygens Jan 15 '15 at 7:19

According to this Apple support article: Set your mac to log out when not in use - installing Yosemite turns on the "log off after 60 minutes of inactivity" feature.

To turn it back off, click on the "Advanced" button at the bottom of the "Security and Privacy" window and uncheck the option. You should be good to go!

  • 4
    I have the logout problem as well, but the automatic logout feature you mention is not enabled. – Copenhagen Nov 5 '14 at 2:06
  • Checked that setting, but it is not enabled. Not sure why Yosemite logs me out randomly... – mdwhatcott Nov 10 '14 at 5:37
  • I called their helpline... And they walked me through a few steps to reset the boot process... But it created another problem. Now it takes 5 mins to log into my account after each shut down... – phoenix Nov 14 '14 at 8:04
  • My MacBook Pro (Retina, 15-inch, Late 2013) has this exact same issue. In addition, I run a VM on VirtualBox, and I can't access it short of killing the process itself. Pain! – JamieJag Nov 20 '14 at 11:02
  • 3
    This is bullshit. Yosemite does not turn ON this option by default! And the link from Apple Support does not support your claim either! – Huygens Dec 20 '14 at 22:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .