13

After upgrading an iMac and MacBook Air from Mavericks to Yosemite, changes to Notifications aren't being retained:

  • Looking at the Notifications Preference Pane - there are a set of apps with Notification settings.
  • Changing Notification settings for any of these apps works - ie I can change the alert style, whether notifications appear in Notification Center, etc.
    • These settings are respected until I reboot / logout, at which point they revert back the original settings.
    • New apps will appear in the preference pane when they are run. Notification settings can be changed. After rebooting, the app disappears from the notification preference pane until I run it again, at which point it appears with default settings.

So what seems to be happening is that these settings aren't being saved to disk. I have:

  • repaired permissions
  • deleted the ~/Library/Application Support/NotificationCenter folder

None of this had made any difference. Does anyone know where these settings are stored?

  • I am having the same issues. Unfortunately, my developer account has expired and I'm not re-upping for probably another month (we are switching over to a business account). This was something I was going to send in on the dev bug reporter. I've also tried everything including an SMC reset. Still no luck. I noticed it because I disable notifications for gfxCardStatus. Now every time my MBPr 15" switches between the integrated and discrete graphics, the banner pops up every time. I went from Mavericks to Yosemite, so it wasn't something to do with going from Mtn Lion to Yosemite. Like you, I can – user96622 Oct 20 '14 at 17:10
  • Same here. As a temporary measure I've disconnected a lot of accounts that generate messages. Too distracting. Will try tekrevue.com/tip/… if i get desperate. – Steve Oct 20 '14 at 20:25
  • I'm having exactly the same problem with the notification center not retaining my settings. Like anu, I've tried repairing permissions and removing ~/Library/Application Support/NotificationCenter and ~/Preferences/com.apple.notificationcenter.plist, but nothing has worked. I need to get rid of those %&*! Facebook notifications!!! – timbck2 Oct 22 '14 at 12:41
  • I'm having this same issue and submitted an Apple Bug report (18762327) for it. – Richard Hurt Oct 24 '14 at 12:23
  • Thanks for including the radar. It sure looks like a bug to me as well. – bmike Oct 24 '14 at 13:05
9

Fixed:

This thread on the Apple forums is the key:

  • Open the Library folder in your Home folder.
  • In the Library folder, open the Application Support folder.
  • Locate the folder named NotificationCenter. Drag this folder to the desktop.
  • Next, open the Terminal application and enter the following

.

cd `getconf DARWIN_USER_DIR`
rm -rf com.apple.notificationcenter 
killall usernoted; killall NotificationCenter
  • Restart your computer.

The issue is clearly to do with the NotificationCenter database. There are 3 files:

  • db
  • db-shm
  • db.wal

In my case db.wal was a 0 byte file compared with 1.9MB on a correctly working Yosemite install. Permissions were correctly set, but looks as if Yosemite wasn't writing to it. Only deleting db.wal didn't fix the problem - another 0 byte file was created on restart. Deleting everything works though!

  • Note: In the forum it is pointed out, that you have to restart the computer 2 times to make the changes work. – Philipp Oct 30 '14 at 9:39
  • You really only need to reboot once. The second reboot really just proves that the fix works. – anu Oct 30 '14 at 10:28
  • 1
    This was super annoying. Your fix worked for me. Thanks anu! – Nick Tiberi Oct 30 '14 at 20:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .