4

I upgraded my Mac to Mac OS X Yosemite.

I had a AMP stack installed via Homebrew on Mavericks and it worked fine.

After upgrading to Yosemite, I have the following problems:

  1. when trying to load phpMyAdmin at http://localhost/phpmyadmin I get the following error:

Forbidden

You don't have permission to access /phpmyadmin on this server.

The error log shows: [Mon Oct 20 11:34:17.235518 2014] [authz_core:error] [pid 70303] [client ::1:50374] AH01630: client denied by server configuration: /usr/local/share/phpmyadmin

  1. When trying to load localhost, I get a blank page. The error log does not have any entries related to that.

  2. I had set up dnsmasq, but now it doesn't work.

When I try to ping a domain name under the *.dev structure, it doesn't respond. It doesn't even time out. Just no response at all, and I have to ctrl-C to exit the ping. However, if I try dig, it gives a response as follows:

 ➜  dig cs.dev

; <<>> DiG 9.8.3-P1 <<>> cs.dev
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 35355
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;cs.dev.                IN  A

;; AUTHORITY SECTION:
.           3600    IN  SOA a.root-servers.net. nstld.verisign-grs.com. 2014102000 1800 900 604800 86400

;; Query time: 38 msec
;; SERVER: 172.16.0.1#53(172.16.0.1)
;; WHEN: Mon Oct 20 12:18:36 2014
;; MSG SIZE  rcvd: 99

I am at a loss as to how to reconfigure my AMP stack to work properly.

Ali

  • Can you post Apache Location / config and output of ls -laR on / Location? (remember to edit out critical data) - update probably changed file rights/ownership of files and it should be quich chmod or chown to fix it. – Marek Bettman Oct 20 '14 at 13:28
  • Not sure what you mean by Apache location, do you mean the directory? – Ali Samii Oct 20 '14 at 16:40
  • That error usually means, that a directory from which phpmyadmin is served (where are it's files) is not readable by the user that owns apache process. – Marek Bettman Oct 22 '14 at 1:33
  • Now, that usually is /Library/WebServer/Documents/ or /users/username/Sites. Apache should run as your user, so the directory where you have phpmyadmin needs to be readable (and some of them writeable as well iirc) by you. You also need to have correct order of Allow and Deny rules in configuration for that Location (there is nice explanation on it at httpd.apache.org/docs/2.4/upgrading.html). – Marek Bettman Oct 22 '14 at 1:43
1

AH01630: client denied by server configuration: /usr/local/share/phpmyadmin

most likely means, that Yosemite upgrade changed file permissions on /usr/local/share/phpmyadmin or changed default apache access settings for the directory where you keep phpmyadmin.

You need to check 2 things:

  1. that /usr/local/share/phpmyadmin is readable by your user and that directories that needs to be writeable by you are.

  2. that you have correct order for Allow and Deny settings for that directory (you either deny from all and then allow from certain locations, or allow from all locations and then disallow from some)

I don't know how did you installed phpmyadmin, but it might have added some config file for it's directory to /etc/apache2/other or /etc/apache2/extra.

4

Since upgrade to Yosemite updated your Apache, you have to update phpMyAdmin.conf to use new Access control syntax.

Have a look at: http://httpd.apache.org/docs/2.4/upgrading.html

In my case I need changed /etc/apache2/other/phpMyAdmin.conf

Order allow,deny

Allow from all

to

Require all granted

More info here: http://www.zoubi.me/blog/you-dont-have-permission-access-phpmyadmin-server-after-upgrading-yosemite

  • This worked for me too – tdc Nov 26 '15 at 21:40
1

I was experiencing a similar problem that to what you described.

To get dnsmasq back up and running, I changed the contents of

/Library/LaunchDaemons/homebrew.mxcl.dnsmasq.plist

to

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
  <dict>
    <key>Label</key>
    <string>homebrew.mxcl.dnsmasq</string>
    <key>ProgramArguments</key>
    <array>
      <string>/usr/local/opt/dnsmasq/sbin/dnsmasq</string>
      <string>--keep-in-foreground</string>
    </array>
    <key>RunAtLoad</key>
    <true/>
    <key>KeepAlive</key>
    <true/>
  </dict>
</plist>

See https://github.com/Homebrew/homebrew/issues/31357 for more details on this and why it works.

0

I experienced something similar after upgrading to Yosemite and it turned out to be that I had camel-cased phpMyAdmin in the bookmarked URL. When I changed it to all lowercase the permission error disappeared. I know this sounds trivial, but I confirmed it on Firefox and Chrome.

I see from your log that this is not the case for you, but I thought I'd relate my experience for others who might run into the same thing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .