0

With the iOS 8 Continuity features you can make and receive phone calls on your iPad or Mac using your iPhone, provided they're all on the same WiFi network and using the same iCloud account.

However, my wife and I both use the same iCloud account and we both have an iPhone. It's the same iCloud account that's configured on the iPad (and on my Mac). In the settings for FaceTime both on iPad and on the Mac, under the heading iPhone Cellular Calls it says These calls will use the caller ID +xxx xxx xxx xxx, and the number is my wife's cell phone number, not mine.

In the situation I'm in (2 iPhones using the same iCloud account in the same house), how can I tell FaceTime which iPhone it should use for the continuity calling feature?

Apart from the caller ID issue, I can't make calls from my iPad or Mac using my iPhone (when my wife's phone is out of the house). It says "iPhone Not Available. Your iPhone and Mac must be on the same Wi-Fi network". However, if I receive a call on my iPhone it appears fine on both iPad and Mac.

0

Ok, figured it out myself. My first problem was that for some reason my phone hadn't activated properly with iMessage / FaceTime (my phone number was unchecked in the You can be reached by FaceTime At section in FaceTime settings). That required switching off FaceTime and iMessage and switching them back on again after a short wait so that they could activate properly, which they did.

Once that was done, my FaceTime settings (on my iPhone) had a new option: iPhone Mobile Calls:

enter image description here

My wife's phone also has that setting. Choosing which phone is used is just a question of only having this setting enabled on one phone at a time. I assume (all though I haven't tried it) that if both phones are enabled in this way, FaceTime on iPad or Mac gives you the choice of which phone/number to use. It wasn't giving me a choice earlier because there was only one phone enabled.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .