2

From time to time (I did not yet figure out a systematic way to reproduce the error) I get an error message when a new Time Machine backup begins: it says that the identity of my Time Machine backup disk has changed (see also this article from the Apple website). I recently made a clean OS X Yosemite install. I also noticed that my Computer name changes automatically from the name I gave it in the first place, MyName, to MyName (2). I am not 100% sure but I think the number in brackets increase with every such error occurring. Is anyone having similar problems? If so, what is the reason, can I avoid it?

I am using a 3 TB Time Capsule (current model) to backup my HDD.

The following are the (I hope) relevant error messages from the console (I think you can see that the name of my computer has changed and the sparse bundle needed was renamed appropriately):

20.10.14 07:23:59,664 com.apple.backupd[14231]: User continued after being warned of changed destination volume identity

20.10.14 07:23:59,676 com.apple.backupd[14231]: Error (-43): Getting volume ref for volume at path /Volumes/Phil-1

20.10.14 07:23:59,678 com.apple.backupd[14231]: Backup failed because the network destination disk was ejected or disconnected unexpectedly!

20.10.14 07:23:59,685 com.apple.backupd[14231]: Backup failed with error 26: The connection to the server was interrupted.

20.10.14 07:24:50,391 com.apple.backupd[14231]: Starting manual backup

20.10.14 07:24:50,392 com.apple.backupd[14231]: Attempting to mount network destination URL: afp://Phil;AUTH=SRP@Phils%20TC._afpovertcp._tcp.local/Phil

20.10.14 07:25:13,042 com.apple.backupd[14231]: Mounted network destination at mount point: /Volumes/Phil-1 using URL: afp://Phil;AUTH=SRP@Phils%20TC._afpovertcp._tcp.local/Phil

20.10.14 07:25:27,239 com.apple.backupd[14231]: Renaming /Volumes/Phil-1/Phils MBP.sparsebundle to /Volumes/Phil-1/Phils MBP (2).sparsebundle 20.10.14 07:26:03,934 com.apple.backupd[14231]: Disk image /Volumes/Phil-1/Phils MBP (2).sparsebundle mounted at: /Volumes/Time Machine-Backups

20.10.14 07:26:05,647 com.apple.backupd[14231]: Backing up to /dev/disk4s2: /Volumes/Time Machine-Backups/Backups.backupdb

20.10.14 07:26:48,008 com.apple.backupd[14231]: Will copy (47,28 GB) from Macintosh HD

20.10.14 07:26:48,012 com.apple.backupd[14231]: Found 93019 files (49,19 GB) needing backup

20.10.14 07:26:48,021 com.apple.backupd[14231]: 61,52 GB required (including padding), 2,64 TB available

  • Can you post the entries from the console which describes the eror? – J.C. Oct 20 '14 at 6:31
4

There seems to be an issue with Yosemite renaming the computer local host by adding (#) after the computer name. There are other reports of this happening in a thread on MacRumors Forum and I believe a few people have blamed this as a cause of time machine backup failures. I've tried a few of the suggestions in the thread but so far none have worked. I've stopped using time machine for now and reverted to an old bash rsync script.

A really simple solution is to open the terminal and type:

rsync -avu ~/ /Volumes/backup_disk/backup_folder

replacing 'backup_disk' with the name of your external hard drive and 'backup_folder' with the name of the backup folder i.e.: 'yosemite_backup'. The three flags -avu mean: archive (a) copy the home directory recursively into sub folders, verbose (v) print to the terminal window everything you are copying (feel free to leave this out) and update (u) will only overwrite files that are newer than the archived file (useful after the initial main backup). This solution isn't as hands off as time machine but at least it's a simple way to back up vital information in Documents and Pictures/Videos.

Edit: 2014/10/28 - I've had success with the following procedure:

Go to Macintosh HD > Library > Preferences > SystemConfiguration and delete the following files:

  • com.apple.airport.preferences.plist
  • NetworkInterfaces.plist
  • preferences.plist

Then remove the numeric iteration (#) from the computer name (or rename altogether) in System Preferences > Sharing and reboot. The plist files will be recreated after reboot. So far this has fixed the computer name issue with Yosemite on my machine and time machine seems to be back on track.

Note: This fix seems to be inconsistent with users and may not fix the naming issue after all.

Edit 2: 2014/11/11 - The above seems to have worked for about 2 weeks but the renaming issue is now back.

  • 1
    Welcome to Ask Different. To flesh out your answer and make it less of a "me, too" comment, can you provide details on your bash script? – tubedogg Oct 21 '14 at 18:15
  • Hi tubedogg, thanks, long time lurker first time poster. I edited the main answer to include the relevant rsync command. – astronomerdamo Oct 21 '14 at 19:39
  • Will the computer be renamed after a next failed TimeMachine Backup? Or is this the issues fixed permanently then? – DaPhil Oct 31 '14 at 6:03
  • Unfortunately I'm not sure. Did you try the 'Edit' in the above answer? If yes, has it worked from preventing (#) being appended to your computer name (after 24 hours without time machine)? My time machine worked alright but I hadn't backed up since yosemite stopped renaming my computer on it's own. I know a few people who have submitted bug reports with apple about this issue so hopefully it is addressed soon. – astronomerdamo Oct 31 '14 at 18:34
  • @astronomerdamo I tried your "Edit", it did not work for me. My computer again added a (2) at the end... So this seems not to be the right solution. Hopefully Apple is aware of this bug and addresses it soon. – DaPhil Nov 4 '14 at 6:15
1

That Time Machine backup no longer belongs to that computer. You did a clean install & broke the relationship between the two.

Time Machine will continue to back up new data to any available space, but it considers the old data doesn't belong to it. You can still use it to manually copy data to the 'new' machine, but "Enter Time Machine" will only go back as far as the clean install.

  • That is not true. I can use time machine to access earlier backups! – DaPhil Oct 20 '14 at 8:01
  • 1
    So could the problem be that the original has the same name as I am using now on the "new machine"? And that is why my computer is renamed? – DaPhil Oct 20 '14 at 8:06
  • @Tetsujin, "I'm guessing so, based on research" is pretty useless. What research? Any link to back that "research"? Or is it pure guessing? – hmijail Sep 2 '16 at 16:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .