1

Does anyone know how I can solve this annoying issue of fullscreen video in Chrome displaying very choppy and jumpy? It's unwatchable. I've had the problem in Chrome ever since I got this 2014 Mac Pro. It's not the Chrome pepper flash plugin because I've disabled that and it's no different, and besides - it behaves the same with YouTube's HTML5 video player.

I've tried disabling all plugins, disabling all extensions, and it still is the same.

Apple won't help as fullscreen video works beautifully in Safari - even 4K Youtube video. The problem exists with Youtube, Vimeo, etc. I have noticed that some news websites videos play fine when fullscreen if the transition to go fullscreen doesn't make the screen blink - like it's trying to change the resolution (like is the case when youtube/vimeo videos go fullscreen, there is a slight blink and delay when going to fullscreen mode). If I try going fullscreen with Facebook videos - the sound plays but the image is black.

Please help - I have no idea what to do. The behaviour is the same in Mavericks and Yosemite.

0

Try disabling Hardware Acceleration...

Control-click the Flash application or video during playback.
From the context menu, select Settings.
The Display panel is the first panel shown.
Deselect the Enable Hardware Acceleration option, and then click Close.

  • Thanks, but as I described it happens in flash AND html5 video players. I had already tried that a couple of months ago in Mavericks and it did nothing, which is also the case in Yosemite. – Jayden Lawson Oct 20 '14 at 11:26
0

After months of this insanely frustrating situation, I'm getting closer.

If you have this issue, try the following:

  • System Preferences > Accessibility > Display > Tick "Reduce Transparency"
  • System Preferences > Dock > Tick "Automatically hide and show the Dock", un-tick "Animate opening applications"
  • Disable any unnecessary items on Startup. I removed the GoPro Studio and a couple of other things
  • I followed this video that has recommendations to speed up Chrome: https://www.youtube.com/watch?v=SMg4l5i8skA

When I use the Yosemite "maximize to fullscreen" button, and then quit and restart Chrome, it starts in this weird half black, and half Chrome window - and then if I make a 4K youtube video fullscreen, it plays flawlessly! Who knows why, but this is the closest I've come yet to getting Chrome to play fullscreen properly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .