6

I just upgraded to Mac OS X Yosemite 10.10.

During the final step of the install, my network connection dropped while trying to set up the iCloud settings. As it says that I can skip this step and configure it later, I did.

Now, I am trying to set up iCloud and upgrade to iCloud Drive.

When I click on the iCloud icon in System Preferences, the App freezes (beach balling) and I am forced to force quit it.

In the Force Quit window, I see System Preferences (not responding) and right below it I see com.apple.preferences.icloud.remoteservice (not responding). If I Force Quit System Preferences, naturally, the whole app quits. If I force quit com.apple.preferences.icloud.remoteservice then I get a notice in the System Preferences app that says Preferences Error: Could not load iCloud preference pane.

In Activity Monitor, I can also see that both System Preferences and com.apple.preferences.icloud.remoteservice are not responding.

In console, I see the following crash report:

20/10/2014 01:46:04.026 System Preferences[4901]: ### com.apple.preferences.icloud instantiatePrefPaneObject exception:service com.apple.preferences.icloud.remoteservice failed to init an instance of iCloudRemoteViewService on behalf of <NSRemoteView: 0x7fb885309930> due to proxy-communications-error: Error Domain=NSCocoaErrorDomain Code=4099 "Couldn’t communicate with a helper application." (The connection from pid 0 was invalidated from this process.) UserInfo=0x618000467100 {NSDebugDescription=The connection from pid 0 was invalidated from this process.}

I am guessing something got corrupted when I skipped the iCloud setup during the last steps of the install process, and perhaps I need to reset/delete the iCloud preferences and let the system regenerate them.

How can I resolve this issue?

7

iCloud preferences seem to be spread across a few different plist files. The main one (funnily enough) seems to be called /Users/YOURUSERNAME/Library/Preferences/MobileMeAccounts.plist. That's the one that stores your account details (ID, UUID, DSID and AlternateDSID) and information about the services you have enabled or disabled.

You could try closing System Preferences entirely, renaming that file temporarily, restarting your Mac and then seeing if System Preferences can then open its iCloud pane.

  • Where (which Library) is that file in? – Ali Samii Oct 20 '14 at 0:05
  • Sorry, updated my answer. :) – Alistair McMillan Oct 20 '14 at 0:06
  • Thanks Alistair. Maybe you have an answer for my other question regarding Alfred (also under the yosemite tag)? – Ali Samii Oct 20 '14 at 0:10
  • Nope, that didn't make a difference! :( – Ali Samii Oct 20 '14 at 0:14
  • Yeah, just tried it myself and it automatically generated a new file with the same information. Also tried renaming the /Users/YOURUSERNAME/Library/Application Support/iCloud/Accounts folder and it automatically regenerated the contents of that too. Given that iCloud is used throughout the OS it might be holding the information in memory constantly giving it the ability to immediately self-heal these awkward attempts (sometimes I miss the days of dopey XP). Or it is storing the info elsewhere. – Alistair McMillan Oct 20 '14 at 0:20
0

In case you don't read through the comments on Alistair's excellent advice above, once you've renamed/moved/deleted /Users/YOURUSERNAME/Library/Preferences/MobileMeAccounts.plist restart. When Yosemite comes back up again, it will ask you for your iCloud password and it should all work.

This does seem to happen if you decline to set up iCloud during the initial install.

You must log in to answer this question.

protected by Community Dec 30 '14 at 10:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .