In Yosemite, when I connect my iPhone to my Macbook Air through USB the iPhone becomes a internet hotspot for my Mac, even though I've connected the MBA via ethernet. If I enable Wifi, then Wifi is prioritized.

Can I change so that ethernet is prioritized over the iPhone?

1 Answer 1

  1. Open System Preferences
  2. Select Network preferences pane
  3. Click gear menu in lower-left corner of Network pane and choose "Select Service Order..."
  4. Drag the services into whichever order you want
  5. Click OK

Screenshot of Network pane with Service Order panel open

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .