It takes a number of seconds before Mac Mail marks a message as "read". I would like for it to take no more than 0.5 seconds, though instantaneous would be best.

How can I adjust the time required to view a message before it is no longer considered "unread"?

Mac OS X, 10.9.4 and 10.10

  • Please clarify if you are referring to Mail.app on Mac OS X (and if so, what version of OS X) or iOS (and again, which version of iOS). Your question references Mac but the tags reference iPhone. Thanks.
    – tubedogg
    Oct 20 '14 at 3:03
  • Great point thank you. iPhone actually does a nice job at instantly marking messages as "read". Oct 20 '14 at 3:08
  • I just tested this and the messages were marked as read instantly, using OS X 10.10. There are apparently no user preferences for this, and Apple removed a "defaults" preference at least two major versions ago, so I am not sure why you are seeing a delay. Is your mailbox very large/are there a large number of messages present? Are you using POP3 or IMAP with your email provider?
    – tubedogg
    Oct 20 '14 at 3:13
  • Brilliant! I am using IMAP. I disconnected from the network and it started marking them "read" instantaneously. I suppose when connected it waits for the server to mark it first. Thanks! Oct 20 '14 at 3:27
  • I added an answer that summarizes the result. If you could "accept" it as the answer, I'd appreciate it!
    – tubedogg
    Oct 20 '14 at 3:30

Have you tried quitting Mail, launching a Terminal and putting in

defaults write com.apple.Mail MarkAsReadDelay 0
  • The 0 in that answer is measured in seconds. In other words if you want Mail to wait a second before marking a message as read change 0 to 1 Dec 28 '14 at 16:12
  • Thank you!! Alas, at long last, this is the real answer. What is the default value of this setting, and must the value be an integer? Mar 5 '15 at 13:04
  • 6
    Unfortunately this no longer works in Yosemite. Apple removed this setting. Jul 12 '15 at 9:50
  • 1
    Is there an equivalent in El Capitan/Sierra?
    – ᆼᆺᆼ
    Aug 9 '16 at 12:08
  • 1
    Mac OS 10.12.6. this works defaults write com.apple.Mail MarkAsReadDelay 0 Instantaneous message as "read" on a IMAP account while online. works perfectly
    – Roped
    Jul 24 '17 at 9:56

When utilizing an IMAP account, you may see a delay in marking read when connected to the mail server, as it issues the mark read command to the server first and waits for a response before doing so locally.

  • Good point - even with the local mail client marking it as read, there can be network delays to foil that quick action and revert the status to unread.
    – bmike
    Jul 24 '17 at 10:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .