3

I just upgraded to 10.10- Yosemite. I have an external 4TB hard drive. These are the problems I see with Disk Utility:

  • No more than two partitions are allowed.
  • Changing the partition size I can only use the slider, so I can't enter a number for the size of the selected partition.
  • Changing the name of the parent partition is not possible.

I tried to repair the drive, that didn't change anything. I can try to reformat, or even format the drive on Linux to something else and then see what DU says about that. Any ideas what is the problem here or is this a case of a bad release by Apple?

  • did you check hidden partitions? Make sure it isn't Core Storage, or has had bootcamp on it, or been used for FileVault, or that you have never tried to adjust partitioning with any other OS than Mac, or that there are partitions between the ones you want to alter. All seem to give issues. – Tetsujin Oct 19 '14 at 18:41
1

I monted the disk on Ubuntu, opened the disk utility and saw the following. It seemed like Apple Disk Utility messed up. I deleted all partitions, then mounted the disk on my mac and I could create three partitions like I wanted.

The partitions

0

Only way for Yosemite Disk Utility to get 3 partitions I have found is to enter repair mode cmd+R and then manually erase Macintosh HD partition and after that it would be possible to get 3 partitions // Only you will need to reinstall OS X from internet recovery

-1

OS X Yosemite includes a recovery partition, the main one and a further one whose use i do not know but these are important so don't delete them. Sorry, you'll just have to work around it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .