1

I recently installed Yosemite, and am now trying to upgrade all of my brew installs (brew update, then brew upgrade). After remembering to do xcode-select --install, I finally got all of my installs upgraded except for encfs and osxfuse (encfs depends on osxfuse). Now, when trying to upgrade, I get the following results (entirety included because it's not that big):

▶ brew upgrade                                                   
==> Upgrading 2 outdated packages, with result:
encfs 1.7.5_1, osxfuse 2.7.1
==> Upgrading encfs
==> Installing encfs dependency: osxfuse
==> Cloning https://github.com/osxfuse/osxfuse.git
Updating /Library/Caches/Homebrew/osxfuse--git
==> Checking out tag osxfuse-2.7.1
==> ./build.sh -t homebrew -f /usr/local/Cellar/osxfuse/2.7.1

OSXFUSEBuildTool()            : supported platforms: 10.9 10.10
OSXFUSEBuildTool()            : building OSXFUSE kernel extension and tools
xcrun: error: missing DEVELOPER_DIR path: 
OSXFUSEBuildTool() failed: xcodebuild cannot build configuration Release.

READ THIS: https://github.com/Homebrew/homebrew/wiki/troubleshooting

Naturally, I've been to the troubleshooting page, and was still not able to solve my problems (although it might've helped me solve problems with earlier formulae). The results of brew doctor are:

▶ brew doctor
Please note that these warnings are just used to help the Homebrew maintainers
with debugging if you file an issue. If everything you use Homebrew for is
working fine: please don't worry and just ignore them. Thanks!

Warning: Broken symlinks were found. Remove them with `brew prune`:
  /usr/local/lib/libosxfuse.la

Warning: Unbrewed dylibs were found in /usr/local/lib.
If you didn't put them there on purpose they could cause problems when
building Homebrew formulae, and may need to be deleted.

Unexpected dylibs:
    /usr/local/lib/libyices.2.1.0.dylib

Warning: You have unlinked kegs in your Cellar
Leaving kegs unlinked can lead to build-trouble and cause brews that depend on
those kegs to fail to run properly once built. Run `brew link` on these:

    fuse4x
    gcc
    ghostscript
    ruby

Warning: Your Xcode (6.0.1) is outdated
Please update to Xcode 6.1.
Xcode can be updated from the App Store.

The results of brew --config are:

▶ brew --config
HOMEBREW_VERSION: 0.9.5
ORIGIN: https://github.com/Homebrew/homebrew.git
HEAD: b7feb05f247b5cf934991d8035bf44ff6c4180ba
Last commit: 43 minutes ago
HOMEBREW_PREFIX: /usr/local
HOMEBREW_CELLAR: /usr/local/Cellar
CPU: 8-core 64-bit ivybridge
OS X: 10.10-x86_64
Xcode: 6.0.1
CLT: 6.1.0.0.1.1413057044
couldn't understand kern.osversion `14.0.0'
GCC-4.2: build 5666
Clang: 6.0 build 600
X11: 2.7.7 => /opt/X11
System Ruby: 2.0.0-481
Perl: /usr/bin/perl
Python: /usr/local/bin/python => /usr/local/Cellar/python/2.7.8_2/Frameworks/Python.framework/Versions/2.7/bin/python2.7
Ruby: /Users/benjaminhocking/.rvm/rubies/ruby-2.1.3/bin/ruby

I tried manually setting DEVELOPER_DIR:

▶ export DEVELOPER_DIR=/Applications/Xcode.app/Contents/Developer

That did not make any difference. Does anybody have any suggestions for how I can fix this?

2
  • 1
    Have you tried updating XCode? You can download it here
    – pczora
    Oct 20, 2014 at 9:44
  • @pczora, that did the trick. I'd noticed that brew doctor had suggested it, but (a) didn't know off-hand how to download it, and (b) was skeptical it would help, so didn't pursue (a). Thanks! Make your comment an answer, and I'll accept it. Oct 20, 2014 at 14:09

1 Answer 1

1

Upgrading Xcode to 6.1 with the link provided by pczora in fact resolved this problem for me: https://developer.apple.com/downloads/download.action?path=Developer_Tools/xcode_6.1/xcode_6.1.dmg

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .