42

I just upgraded to Yosemite and my current best interpretation of what's happening is that there's a new behavior that "helpfully" moves the mouse (and a window if you're moving one) closer to an edge of the screen when moving quickly enough.

I really dislike this, in great part because it causes very strange behavior when I'm playing a game.

Is this a setting that can be changed?

With additional testing, it looks like the mouse doesn't snap to the edge, but has tremendous acceleration in some cases (quick changes in direction?) which it didn't have before the upgrade to Yosemite.

  • Yeah, why add a "feature" that makes the mouse practically unusable, then not provide any easy way to turn it off. – samthebest May 9 '17 at 18:37
  • So I got pretty side tracked and ended up making a bash script using the defaults write .GlobalPreferences com.apple.mouse.scaling -1 method as a way of toggling mouse acceleration here: github.com/alfiedouglas0/mouseacc. Thought I'd post it here incase anyone finds it useful! – Alfie May 25 at 23:51
42

It turns out Yosemite enables mouse acceleration by default. it can be disabled by typing this in terminal:

defaults write .GlobalPreferences com.apple.mouse.scaling -1

After changing this setting in Terminal, you'll need to logout and log back in to your Mac. Relaunching Finder will work too (option + right-click on Finder icon in dock -> Relaunch)

  • 1
    It does decreases acceleration significantly, but doesn't set it to 0. Checked with both mouse and track pad. Also you can't change mouse speed in this case. Just fixed two points on the table and moved mouse slowly left and quickly right - that way cursor can be moved to any position to the right. I would appreciate if anyone can conform it. – klm123 Nov 9 '15 at 11:18
19

Even with mouse acceleration turned off, OS X uses an 'acceleration curve', which makes the mouse slower and the movements less linear.

To disable the acceleration curve/set it to a linear one, download Steelseries Exact Mouse Tool, open it and set it to 'always on'(there will be an icon in your menu bar).

It doesn't just work with Steelseries mice, I use it with my razer mamba in combination with their drivers and it works perfectly.

  • Awesome. Worked straight away. No install either. I'm using it with my Logitech M705. – vaughan Sep 14 '16 at 20:15
  • Note: No restart/logout required. And you can disable and re-enable at your leisure. – Christopher Bull Nov 8 '16 at 13:36
  • This appears to work effectively on El Capitan with my 'ancient' (~10 years old) Logitech MX518. – Adam S Dec 17 '16 at 2:02
  • Awesome, but how do I control the sensibility? It seems to override the "tracking speed" set in System Preferences. – Leonardo Raele Jan 11 '17 at 16:42
  • This application works horrible in 10.12. If you try it, you will feel that when you move mouse fast enough it stutters. – Nik Jan 19 '17 at 18:12
4

USB Overdrive remains the best way to control mouse speed/acceleration in OS X, in my opinion. Apple's mouse driver is appallingly bad.

  • This program refuses to stay installed. annoying. – ahnbizcad May 14 '15 at 16:51
  • It doesn't actually help. In allows to decrease mouse acceleration, but it is always present even when USB Overdrive shows that it is turned off completely. – klm123 Nov 9 '15 at 11:03
  • @klm123 That's strange; maybe your device has some hardware-level acceleration? I can move my mouse slowly from the left to right extremes of my wrist's rotation, then snap it back quickly, and repeat that dozens of times and the pointer always returns to exactly the same horizontal position on the screen. – Brian Gordon Nov 9 '15 at 23:23
  • @BrianGordon, thank you for information. That mouse worked with windows perfectly. Strange, I agree. – klm123 Nov 10 '15 at 8:14
2

Using defaults write .GlobalPreferences com.apple.mouse.scaling -1 doesn't let you set your mouse speed.

I tried USB overdrive and it does the job even if I'm sure there are other applications that handle this.

1

I highly recommend the program called smooth mouse. It works perfectly for me.

It enables you to choose different settings for the mouse and trackpad (acceleration on trackpad is highly desirable, in contrast with the mouse).

It can be downoaded for free here: http://smoothmouse.com/

  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan May 26 '16 at 20:41
  • 1
    SmoothMouse is amazing tool, but it is not supported on Sierra. Is there any similar one? – Avseiytsev Dmitriy Jan 13 '17 at 14:41
0

If you have a razer product and use razer synapse the following apply:

The acceleration can be reenabled on OS X update. To disable again just drag acceleration up and then down to 0 again and the issue is fixed.

  • True, but that's specific to Razer products on a computer with Synapse installed. Ideally, a more general solution could be spoken of. – JMY1000 Jun 6 '16 at 10:00
  • Well I looked at the mouse configuration, razer basically sets the mouse track speed in OS X to 0, so this only works for mice with very high DPI settings. Alternatively USB overdrive is a good way to go. I just wanted to give an easy solution for razer users as an extra answer to the existing ones – Warpzit Jun 6 '16 at 10:29
0

I can't comment yet but I also want to chime in for USB overdrive, which works with El Capitan.

But just having the USB overdrive driver does not remove mouse acceleration even after unchecking the Acceleration box within the driver settings. You also need to go to the OS X Mouse Settings panel and set Tracking Speed all the way to Slow. You can still adjust mouse sensitivity by modifying the Speed slider in the USB Overdrive panel. I can confirm that moving my mouse at any speed will move the cursor a consistent distance.

  • @klm123 FYI about USB overdrive – bernie Jun 20 '16 at 17:54

You must log in to answer this question.

protected by Community Feb 16 '17 at 9:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .