3

Yesterday I updated my 2012 MacBook Air to Yosemite. Everything was good, everything working great, but, at the end of the night, my laptop’s battery was low so I decided to shut it down, instead of just sleeping it.

Today when I turn on the laptop, it won't do anything. I just get the chimes sound and a gray screen, with not even the Apple logo, and that’s all.

I have tried booting pressing command+R, command+option+R and option+S but that did not work.

The only way it tries to boot is by booting with command+option+R+P: It restarts then the Apple logo appears, but after that, if I try to login to my account, it gets stuck at 50%, no progress; I left it for 8 whole hours and it didn’t move.

I turned it on with command+option+R+P, after it restarted, I pressed command+S for Internet Recovery but I got an error, that flashed very fast before the login screen displayed, after several tries with my phone I took a picture and got the error:

Command-S Error

After that error, the login screen appears and if I try to login I get this black screen and just get stuck there, with no more progress:

Login error

I'm able to enter as a Guest User, but it only let me use Safari—I don’t even have a menu bar or anything.

Since it's a MacBook Air, I can't remove the SSD so I don’t know what else can I do.

  • not an answer, but Cmd/s is single user mode, not recovery; that's Cmd/r – Tetsujin Oct 19 '14 at 16:22
  • What happens if you shut it down & restart just holding onto the option key? That should give you the “Startup Manager” screen which will let you choose a startup disk. Also if you have a USB drive—thumnbdrive or other—you might be able to boot from that to get some kind of disk repair to happen. support.apple.com/kb/ht1310 – JakeGould Oct 19 '14 at 16:34
  • I did the Option key boot, i was able to select the default ssd to boot, and after login in i got a gray screen with a "no" sign (gray circle with a diagonal bar inside, like the deny sign). Any idea of what can that mean? – Javis Perez Oct 19 '14 at 16:46
  • @JavisPerez You should boot up from an external disk of some kind & run disk utility to repair the disk. – JakeGould Oct 19 '14 at 16:54
  • @JakeGould i just boot up from an usb stick with a fresh Yosemite Install, and i think i found the problem. The disk seems to have 0 bites left, so maybe is trying to write some cache or tmp files and cant. I want to erase the disk with the Disk Utility but it just loads to infinity and does nothing, is there a way to erase the SSD from the terminal in the memory?, just to ensure no tmp file is needed. If i try to make a new install, it ask me to unlock the drive, after that, loads a few minutes and nothing happens, just says "Yosemite will be install on -disk-name- ". Ideas please? – Javis Perez Oct 19 '14 at 21:38
3

If you go into the screen that lets you re-download the OS and also gives you the ability to see disk utility command + r during bootup.

Run disk utility and select the Mac Harddriive [not the OS partition] and run the Repair Disk Permissions feature and then restart the computer and you should have a permanent solution to the black/gray screen.

RECAP [make sure computer is off]:

  1. Turn on Mac
  2. Hold command + R as system boots up
  3. When in recovery mode select a Computer Harddriive [not the OS partition]
  4. Run Repair Disk Permissions
  5. Reboot
  • Yes! Thank you! this worked!! i mean, kind of, haha, but i got my computer back! This is what i did thanks to you! Command + R didn't work, because i got the same gray screen, so i booted from an USB Install, opened the disk utility, and instead of repearing the partition, i did to the disk as you said, the partition disappeared, i created a new one and reinstalled the OS, and it worked, thank you! i lost some files but its ok, thanks a lot! – Javis Perez Oct 26 '14 at 16:10
3

I have a Mac desktop that I updated to Yosemite. After an initial start, it kept going to blank gray screen in the middle of bootup. I have several accounts on this machine. I finally restarted in safe mode and after logging on to my administrative account the Mac informed me I had a piece of incompatible software -- "Instant On". This was automatically moved to the "Incompatible Software" folder and the installation finished. I have done a shutdown and restart and all appears fine.

2

What happens if you shut it down & restart just holding onto the option key? That should give you the “Startup Manager” screen which will let you choose a startup disk; more details from Apple’s site. Also if you have a USB drive—thumb drive or other kind of drive—you might be able to boot from that to get some kind of disk repair to happen.

When you boot up from another disk, I would recommend Disk Utility repair the disk. If that does not work—and you are sure there is nothing on the disk you need—then perhaps you can erase the disk. But that is a bit of a radical solution.

I would recommend launching Terminal form the USB disk and then looking at your disk usage. Maybe the disk is full or near full? If so, that might be the problem. I would then recommend you go find something you know is taking up space and simply delete from the command line.

The first command I would recommend you run is ls -lah on the /Applications directory like this:

ls -lah /Applications/

Look for any large sized files you can toss. The most obvious one in my mind would be the Mac OS X 10.10 Yosemite installer. It should be named Install OS X Yosemite.app. To get rid of that just run this command:

rm /Applications/Install\ OS\ X\ Yosemite.app

The backslashes are to escape the spaces. You can also run it like this with quotes around the filepath:

rm "/Applications/Install OS X Yosemite.app"

After doing that, try to reboot from your MacBook Air’s hard drive. It should work.

When you are back in the system, I would see about clearing out more space. First, manually look around for stuff you are 100% positive you can toss or copy elsewhere like stuff in your personal ~/Documents/ directory. Then I would recommend you download Onyx. There are different versions for different OS versions and while it doesn’t seem like a Yosemite version has been released yet, I would expect that to appear in a few days. Run that to clear out deeper system data & caches that might be taking up space.

UPDATE: According to the comments from the original poster, the system disk for the MacBook Air won’t even mount. If that is the case, then I recommend resetting the PRAM or NVRAM depending on the make/model of your MacBook Pro.

Instructions for dealing with the PRAM are here on Apple’s site; ignore the title that refers to Mavericks since those instructions should work with all version of Mac OS X:

  1. Shutdown your Mac.
  2. Start your Mac.
  3. Immediately hold down the command + option + p + r keys.
  4. You will hear the Mac OS star up chime once, and then once more as it restarts form the PRAM being reset. After the second “BONG” sound let go of the keys & boot up as normal.

Instructions on how to reset the NVRAM are here. It seems a tad more daunting but not really that hard to do:

  1. Shutdown your Mac.
  2. Start your Mac.
  3. During starup hold down the command + option + o + f keys.
  4. When you get into open firmware—which should look like a terminal prompt—type in the following two commands:

reset-nvram return

reset-all return

Your MacBook Air will now restart with cleared NVRAM settings.

  • Great, thats a great answer, thank you! just one problem :-( im unable to mount the disk, so i can delete something, seems like it doesnt even have space to mount the disk, im in the usb but can browse the main disk, just the usb, because it wont mount. Any alternative on how can i get the disk mounted? Thank you for all the help! – Javis Perez Oct 20 '14 at 0:56
  • @JavisPerez Oh wow. So the system disk on the MacBook Air won’t even mount? I would recommend resetting the PRAM or NVRAM. Look at my latest edit to see what I mean. Past that I am not too sure. – JakeGould Oct 20 '14 at 1:04
  • Ok, i did reset the PRAM, but i can not reset the NVRAM, i follow the instructions and nothing happens. After reseting the PRAM, it gets to the login screen, but when i try to login,i get stuck at 50% of the progress. Im thing about booting while pressing T key to boot as external drive and use a thunderbolt cable to try to mount it on another computer and delete some stuff. What do you think? i have never done that, just read it online. – Javis Perez Oct 20 '14 at 13:39
  • 1
    @JavisPerez I have no idea what to do next. I would recommend bringing it in for service. That said, if you found my question helpful please remember to up vote it. And if it is the answer that solved your problem, please be sure to check it off as such. – JakeGould Oct 20 '14 at 14:14
  • Of course i will, ill vote up but not yet mark as answer, because if i fixed with another solution i'll post it as answer, to help anyone with similar problems, ok for you? – Javis Perez Oct 20 '14 at 14:40

You must log in to answer this question.

protected by Community Dec 6 '14 at 8:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .