5

Since upgrading to Yosemite (from Mavericks) my MacBook Pro (Retina mid 2014) is visible (in "advertising mode") on Bluetooth (at least to my iPhone). It was not visible prior to Yosemite, and there's nothing that I did on my iPhone (that I can recall) to make this happen.

Why is my Mac visible on Bluetooth, and how do I hide it again?

  • Please don't change the question after you've received a first answer, it makes for both bad questions and answers. Either followup on the answer to get additional details or ask a new question referencing this one – nohillside Oct 19 '14 at 16:39
  • If this is Handoff (as it appears to be from some answers below), at what point in the Handoff setup (or enabling/disabling) process does my machine become visible/invisible? Does it advertise for as long as Handoff is enabled; does it stop as soon as it's not? And to what devices is it visible (e.g., just devices using the same Apple ID?) Also, a command line way of enabling/disabling would be great (I'd like to turn visibility on/of with a script). – orome Oct 19 '14 at 18:19
  • Please use the "Ask Question" link on top to ask this as a new question. – nohillside Oct 19 '14 at 20:35
  • @patrix: See the link in the comment and this. – orome Oct 19 '14 at 20:55
  • What does "visible on BlueTooth" mean? Can you post a screen shot of your phone that shows what you mean by "visible"? – Ian C. Oct 19 '14 at 22:16
7

Bluetooth needs to be in advertising mode for Yosemite's Handoff to work.

To disable Handoff in Mac Yosemite: Select System Prefs > General and uncheck "Allow Handoff between this Mac and your iCloud devices".

System Preferences → Allow Handoff between this Mac and your iCloud devices

  • At what point in the Handoff setup (or enabling/disabling) process does my machine become visible/invisible? Does it advertise for as long as Handoff is enabled; does it stop as soon as it's not? – orome Oct 19 '14 at 13:35
  • I don't have any info on that & can't test as I don't have a BT4 Mac, but as Handoff is supposed to permanently live sync your devices, one could presume it would be always-on. If it can see your phone, it can pick up a phone call, etc; otherwise it would have to go hunting for a device that wasn't announcing its presence.. right when it needed to be. – Tetsujin Oct 19 '14 at 13:37
2

Looks like the three ways Macs become discoverable (showing up in other computers) via Bluetooth are Bluetooth Sharing, Handoff, and when the Bluetooth Preference pane is open.

To keep your Mac from being discoverable via Bluetooth, do the following:

  1. Select Apple menu->System Preferences...
  2. Select Sharing.
  3. Turn off Bluetooth Sharing, if it's on.
  4. Select View menu->General.
  5. Turn off Allow Handoff between this Mac and your iCloud devices, if it's on. (This option won't appear on older Macs.)
  6. Keep Bluetooth Preferences closed except when pairing with another device.

You can check discoverability from another Mac as follows:

  1. Select Apple menu->System Preferences...
  2. Select Bluetooth.
  3. Wait a while to see if your computer appears.
1

I've got the same problem - the issue seems to be with Yosemite's insistence to make your MacBooks' bluetooth discoverable in case you want to use the Handoff feature - but the problem is, there are plenty of MacBooks out there which are fast enough to run Yosemite, but too old to support Handoff. In which case, the "Allow Handoff between this Mac and your iCloud devices" tick box is missing and the only way to stop your Mac from advertising its presence via bluetooth seems to be to turn off bluetooth completely. Very annoying!

Missing Handoff selection example

  • Woah - could you edit your post to explain which model Mac you have? About this mac will have text like MacBook Pro (Retina, 13-inch, Early 2013) or system information has a line like MacBookPro10,2 – bmike Mar 6 '15 at 16:40
1

Use "Pref Setter" to change the Settings in the Bluetooth System preferences:

  1. Start "Pref Setter"
  2. Search for "Bluetooth"
  3. In "System Preferences" -> com.apple.Bluetooth -> doubleclick -> find "DiscoverableState" -> change to "false".
  4. Close window with cmd-w, safe, exit.
  5. Restart (disable/enable) bluetooth.

Don't be alarmed when opening the bluetooth menu. To confirm that this has worked, check Bluetooth state with alt-click on the Bluetooth menu; it should read discoverable: no.

-3

Spent hours searching on a solution for this problem but Jawa's answer was the correct way to solve it. Thanks!

  • 1
    Since Jawa doesn't have an answer here, could you edit this to explain what did fix this for you? – bmike Mar 6 '15 at 16:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .