19

When I drag music files from iTunes (desktop) onto a connected iPhone, many times the files just don't copy to the iPhone - the tracks appear in the list on iPhone, albeit grey and the most-left column is a dotted circle with a to me unknown meaning (it might be a progress bar really...).

iTunes 12.0.1.26 (OS X Yosemite)

You can see some of the files copied, while others did not, in the screenshot:

enter image description here

The dotted circles are in the left-most column.

I'll list some things to rule out:

  • Not using iTunes Match.
  • I do have enough space on the iPhone. It's a new iPhone 6 Plus 128 GB, with about 60 GB free space.
  • I do have "Manually manage music and videos" selected.
  • I can copy some files, some files just won't copy. Even in the same drag manoeuvre, some files would copy and some will not.
  • Similar: apple.stackexchange.com/q/66508/11632 – Jonny Oct 19 '14 at 13:07
  • Could you attach an image of the dotted circle? – woff Oct 19 '14 at 13:10
  • Done. This happens kind of random it seems, and I've had this problem for quite some time really but never found a solution. – Jonny Oct 19 '14 at 13:13
  • 3
    I can answer this, but the SE engine says I can't because it's a protected question and my 101 rep isn't enough - I need 10. Anyhow, what worked for me in this circumstance is to go to the bottom of the page and press 'Sync' - at the end of the sync process, iTunes would start copying the missing songs. I had to sync three times to get 120 missing songs over, but they eventually arrived. – Adam Lawrence Jul 20 '15 at 1:41
  • 2
    None of the answers helped me with automtatic sync. Manual sync is easier, it usually gets it done, until it doesn't. Then it's restore and try again. Automatic sync is absolute garbage, and manual is less than acceptable. I'm starting to suspect they're hashing songs/episodes so weakly that it fails to copy them because it "thinks" there's a duplicate. I miss the iPod classic so much... – Mena Jul 6 '16 at 22:18

12 Answers 12

5

I've observed this issue with several iPod Touch devices (one V1, one V4). It only started for me when I moved my music files from my main PC HDD to a Wi-Fi connected NAS.

My workarounds are as follows:

  1. I don't copy more than one album at a time (manually manage music).
  2. I wait for the previous copy to finish before starting a new one.

When I do get items with the grey circle, I sync the device. At the end of the sync process, iTunes will start copying the missing items to the iDevice. It may take several syncs to clear up the issue, but it should eventually get your items over.

4

You guys. I solved this. I don't know if this is the right or only way to fix this problem but it worked for me. It took forever, but it worked.

Delete all of the songs of your iPod/iPhone that have the little circle.

Drag them back onto your device, one by one.

It's the only way it worked for me! If I tried to drag a bunch of them it never worked.

I hope this helps someone!

2

Ignore all the rest of this crap, all I did was change the name of one of the songs that wasn't syncing. After I did that I hit sync and they all started syncing. Hope this works for whoever reads.

  • This worked for me. I went into iTunes > Library > Songs (not to be confused with iTunes > Devices > Music. Then found a song that wasn't syncing. Clicked to select the row. CMD + i on the song to bring up info. I modified the Comments input. Click OK. Go back to devices and sync. Viola! – styfle Nov 21 '18 at 13:35
1

I think this was due to my files have a heart shape in the filename. I renamed to remove it, re-added to my library and on next sync it worked. It may be as simple as illegal characters. Apples much vaunted user interface gives zero clue to the cause, leaving the user to guess. A simple mouseover the dotted circle with the issue revealed as a tooltip would have eliminated all this frustration.

  • Unhearting the album fixed the problem! – Hatef Apr 14 '18 at 13:16
0

I found this article which seems to have the answer...

http://robservatory.com/a-nasty-little-itunesios-bug-may-be-causing-media-sync-issues/

0

What I do is delete the album and add it again. If a song isn't on there I manually delete it and add it back in. It is a longer process but more efficient.

0

I deleted the songs that were greyed out and then re-dragged them to my phone from my music library

0

I had this problem for a while, figured out how to fix it, i created a playlist on my iphone, when i go to drag songs into my ipod i drag them into the playlist which throws them onto the phone and the playlist (not a big deal) and boom, every song I re-tried and every single one is now on my iphone. Hopefully this works for everyone else.

0

I had this same problem. I spent a lot of time reading other solutions and playing around. I even considered wiping my phone's content and starting over.

In my case I believe it was because I had purchased an iTunes pre-release album, downloaded those tracks, and then when the album was finally released I ended up having duplicate (purchased) tracks.

Although I suspect there are other ways to end up with the same issue, anyone reading this I would consider two things. First, look for duplicate tracks specifically from iCloud, and remove the dupes. Here are instructions from Apple: https://support.apple.com/en-us/HT201323

That wasn't all though, I then had to nuke the music on my phone and re-sync everything. This was rather involved:

  1. Connect phone to iTunes
  2. Select Music under Settings
  3. Turn off Sync Music
  4. Click Sync
  5. Observe that there was still a lot of space being used by (now unsynced) music
  6. Disconnect phone and manually deleting what was left on the phone: Settings -> General -> Storage & iCloud Usage -> Manage Storage -> Music -> Edit / All Songs -> Delete
  7. Reconnect phone to iTunes
  8. Go back to Music under Settings
  9. Choose "Sync Music" (selected playlists, artists, albums, and genres), and re-select the music I wanted synced
  10. Click Sync then Done

I hope this helps.

0

I had this problem several time. Just now i found a "fix" Next to the "eject" icon on your iphone-tab in tunes i found a warning exclamation mark. clicking on it sums up all the erros that happened while copying. After clicking OK - the whole copying continues..
worked for me! ;)

-2

That is happening because after the last update apple has blocked the option to copy music that has been dowloaded previously or that has been download from the internet. Now you are forced to buy again your music and also users will not be able to listen internet downloaded music, so we could say that apple is fighting against ilegal downloads. Until now there are no solutions to this problem.

  • Any official reports about this ? – Jash Jacob Nov 2 '14 at 1:27
  • That doesn't make any sense. First, Apple has no way to know if a file was downloaded from the internet (and if so, whether it was legitimately acquired or not). Files that you rip yourself, using iTunes or another tool, can be identical to files downloaded from the internet. If they were really trying to "force[] [you] to buy again your music" they would block ripped tracks too, which you do not claim they do. And finally, Apple has nothing to gain by doing this. The revenue generated by the iTunes store (which gives you non-DRM AAC files, btw) pales in comparison [continued] – tubedogg Nov 4 '14 at 6:37
  • [continued] to the revenue from devices. Since the files no longer lock you into their devices, they have no incentive to try to somehow block MP3 or AAC files not acquired through iTunes. – tubedogg Nov 4 '14 at 6:41
-3

FIX IS EASY...... SELECT THE TRACKS WITH THE DOTTED CIRCLES IN ITUNES WINDOW... THEY GO BLUE.......THEN RIGHT CLICK IN THIS WINDOW WITH ALL THE TRACKS HIGHLIGHTED IN BLUE.... THEN SELECT THE DE-SELECT OPTION ... SO THE TICK IS GONE ON THE FAR LEFT OF THE SCREEN NEXT TO EACH TRACK...... THEN... RIGHT CLICK AGAIN.... AND SELECT "SELECT" OPTION SO THE TICK RE-APPEARS..... AND ALL TRACKS HAVE A TICK AGAIN.... THIS RE TELLS ITUNES WHAT TO SYNC.....THEN CLICK SYNC..... VOILA... WORKS FOR ME IN EL CAPITAN - 10.11.6 - ITUNES - 12.4.3.1 :)

  • Please fix your CAPS Lock key, posting stuff in all upper case is considered as shouting and therefore very rude. – Byte Commander Aug 8 '16 at 11:42

You must log in to answer this question.

protected by bmike Aug 9 '16 at 9:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .