1

I have a MacBook Pro 13' retina from April 2013. Yesterday I wanted to do a clean install of Yosemite. I formatted my USB as Mac OS Extended (Journaled) and made the partition to be a GUID table partition.

Then I run this command to copy the bootable installation files of Yosemite to the USB:

sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction

Everything went fine and to be sure I verified with Finder that the installation really was in the USB and not corrupted.

Then I rebooted my MacBook Pro, held the Options Button to get into the boot menu but there my USB wasn´t listed, only the harddrive and the recovery partition. I also tried the other USB port but id did not help. I have googled a lot of this issue but I haven´t found anything that helped. I have also tried the whole procedure of formatting the USB and putting the installation files 3 or 4 times now.

After some hours of tries to boot the USB I gave up. What I did instead was to open Disk Utilties (from my recovery partition) and format the harddrive, then install Mountain Lion and then make the upgrade to Yosemite. But that is not a clean install.

Any ideas why I could not boot from the USB?

1

I had the same problem. You have to drag the file from finder into terminal to get the official name of the installer. The end result is something like /Applications/Install OS\ X\ Yosemite.app

At least that is what worked for me.

Hope that helps.

0

I was having the same issue. Made a bootable Yosimite USB, and when checking if I could select the USB at startup it wasn't showing up when using the option button at boottime.

I could however select the USB in the "Start-up disk" from the System Preferences, and the system would actually boot from the USB.

Now, I did get it working by pressing the C button at boottime, see also: http://support.apple.com/en-us/HT201255. It did take quite a while before the USB actually started loading though, so have some patience :-)

Hopefully this works for you too!

-1

I just got the same problem - I only had my hard drive and recovery. So I unplugged the USB and plugged it in again with then boot screen still up and it appeared!

Someone call the IT Crowd!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .