0

I just updated my MacBook Pro (Early 2011) to OS X Yosemite, now iMessages is no longer working. I turned it off/on on both my computer and my iPhone, reset my Keychain, and a bunch of other stuff. Nothing worked.

How can I fix this ?

0

After an hour long call with Apple, I was finally told to reset my default Keychain, and after a reboot, that worked. We diagnosed this as the issue because every time I rebooted, iCloud/FaceTime/Messages would ask for my password again, even though it had supposedly saved it.

This also came right after I had just reset the default Keychain to solve not being able to connect to my wireless network.

-2

You'll just have to wait till iOS 8.1

Some of the information contained in this post requires additional references. Please edit to add citations to reliable sources that support the assertions made here. Unsourced material may be disputed or deleted.

  • Welcome to Ask Different. Please expand on your answer. Is there a specific bug being fixed in iOS 8.1 that resolves this issue? How do you know iOS 8.1 will fix the OP's issue? – tubedogg Oct 19 '14 at 19:23
  • This would be true for SMS, but the original question was about iMessages. – Andrew Min Oct 20 '14 at 23:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .