14

I have some filters set up in Gmail, for things like mailing lists. Messages skip the inbox, get tagged, and go straight to archive. This was not a problem in Mavericks, but now I'm getting the "new mail" noise all the time, when really it's a new message in the archive, from one of these filters, but nothing is new in my inbox.

The setting in my preferences is still: New message notifications: Inbox Only.

Any ideas? A bug in Mail?

  • Permissions? Where? Is this an accidental comment on another question? – Rob N Oct 19 '14 at 2:22
  • NOPE, not a typo, see this for instructions macissues.com/2014/04/11/… – Ruskes Oct 19 '14 at 3:38
  • I don't see how the linked article has anything to do with the issue at hand. I am also experiencing the same problem with gmail filters sending items to the archive but keep getting the "dings". Note: though the "dings" are audible there aren't any notifications that slide over. I too would like it to stop :) – sdavids Oct 19 '14 at 5:28
  • @sdavids If you have a user preference setting that system does not accept (keeps doing as before) then usually it is a problem with broken user ACLs (permissions). – Ruskes Oct 19 '14 at 5:45
3

My workaround…

  • Switch off the new message sound in Prefs > General

  • To the end of every rule, or at least the end of all possible paths, add a new Action - 'Stop Evaluating Rules'.

  • Add one more Rule at the end, like this…

enter image description here

Anything that gets that far through the Rule list will play the sound, anything diverted on the way will not…
...or you can selectively add that or any chosen sound at the bottom of earlier Rules, for instance if you wanted to differentiate or highlight any particular incoming path.

0

I haven't used the client side mail filters for while, but I don't think it's a bug.

As a alternative workaround you can use server side gmail filter. So, incoming email messages, like mailing lists are already sorted on the server before they show up in Mail. It is so much faster than sorting them locally.

  • I was not talking about client side filters. I have the filters set up in Gmail. I haven't tried this El Capitan, so I'm not sure if it's still a problem. – Rob N Jul 5 '16 at 0:43
0

Go to Mail -> Preferences -> Rules.

Edit one of the lists, where you have to add under "Perform the following actions:":

Mark as Read

0

Solution: update your Gmail filters to:

  • Skip the inbox
  • Mark as read

You must log in to answer this question.

protected by Community Oct 24 '14 at 17:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .