9

I just updated my MacBook Pro 13 inch mid 2012 model to OS X Yosemite, and the icons on my desktop are behaving strangely. When I try to move a file or folder to a specific place to keep my desktop organized, it doesn't let me put them where I want them to go.

Below is a screenshot of my desktop. I tried to move the folder with the red 1 on it into the empty space where the 2 is, but it wouldn't let me, and the folder moved back to where it was. However, if i were to move the folder to the number 3, it would let me do this. Screenshot

0

3 Answers 3

9

I pressed command-j, changed the font from 12 to 11, changed "sort by" from "snap to grid" to "none", moved my icons where I wanted them, put "snap to grid" back on, then control-click and selected "clean up" to move all the icons back into the alignment of the grid. Since doing this, I have not experienced this problem.

4

By no means a scientific answer, but when this happened to me, I eventually got round it by...

Closing all windows [to save confusion]

Dragging all the icons over to the left side of the screen, Hit Cmd/J & set Sort by to None [from Snap to grid previously]

Right clicking the desktop then setting to Clean up by Name, then Sort by Size [or anything other then name]

Then set to Sort by None, Sort by Snap to Grid, then manually moving the icons back where I wanted them.

This time they stayed where I set them.
Essentially I think I just shook up all the prefs & made it have another look.

If still no joy, then run Disk Utility & check permissions & verify/repair disk & try the shake-up again.

3
  • I tried this, and it seemed to work at first, but after rearranging some of my desktop items, the same thing kept happening. Oct 20, 2014 at 0:57
  • try the View panel again, Cmd/J, try a smaller font size; see if it doesn't like titles overlapping.
    – Tetsujin
    Oct 20, 2014 at 6:31
  • 1
    I decreased the font size from 12 to 11, and my desktop seems to be cooperating now. Oct 26, 2014 at 19:21
3

Right click the desktop, and hit clean up. I had the exact issue and clean up fixed it!

1
  • 2
    +1. This should be the accepted answer. Straight to the point. Feb 22, 2017 at 1:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .