I have this weird issue, where my cursor isn't changing to a pointer (or any other cursors) when I'm browsing the web or in Mail.

MBPr mid 2012, OS X Yosemite, Safari 8

Anyone knows how to fix this?

  • hardware? OS ? Safari version ? – Buscar웃 Oct 18 '14 at 23:02
  • @Buscar웃 MBPr mid 2012, OS X Yosemite, Safari 8 – Angelo A Oct 18 '14 at 23:04
  • 1
    see this discussions.apple.com/thread/5105399?start=0&tstart=0 by Linc Davis! – Buscar웃 Oct 18 '14 at 23:12
  • @Buscar웃 thank you, the safe mode solution fixed my problem. No idea what caused it actually. – Angelo A Oct 19 '14 at 0:13
  • OK, lets make this a answer to be able to close this. – Buscar웃 Oct 19 '14 at 0:19
up vote 0 down vote accepted

I found a article how to fix that on Apple Support Communities by Linc Davis.

This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

Step 1

The purpose of this step is to determine whether the problem is localized to your user account.

Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

Test while logged in as Guest. Same problem?

After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

*Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

Step 2

The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login, or by a peripheral device.

Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.

Safe mode is much slower to boot and run than normal, and some things won’t work at all, including Wi-Fi on certain iMacs. The next normal boot may also be somewhat slow.

The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

Test while in safe mode. Same problem?

After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • 1
    The answer below about Photoshop CC turned out to be the reason. If you have an Adobe – Nilloc Jun 30 '15 at 5:52

If Photoshop CC runs, the mouse pointer can show you wrong pointer in several different apps (Chrome, Mail, etc.). Close Photoshop CC and the cursor should be OK.

Reference: https://code.google.com/p/chromium/issues/detail?id=357347

  • 2
    FYI This is not just limited to Chrome, your solution just worked for me in Safari 8.0.6 as well. Thanks! – Thomas Jun 24 '15 at 18:38
  • 1
    I was going insane with this! Closed Photoshop and now all cursor assignments work perfectly. Cheers! – Joshua Pekera Aug 11 '15 at 16:18
  • This fixed it for me but the issue isn't only with CC, I'm running CS6 and occurring. Recently updated to El Capitan, not had it happen before. – Brad Adams Oct 23 '15 at 16:20
  • Aha! It's Photoshop!!! Closing PS fixes it immediately in all apps. – Django Reinhardt Nov 2 '15 at 13:34
  • Yep this is the problem. Closed Photoshop and everything was working fine – Jesse Kinsman Apr 4 '16 at 22:14

I'VE FOUND THE PROBLEM!!!! WHOOORAHHHHH!

ADOBE it's you!

Flickering curser / curser not showing / jiggering around all over etc in all adobe products and your browser with ADOBE flash plugins!

A team of 22 people in my office all had similar issues and we resolved it simply by closing our currently open photoshop documents. Why this fixed it we have no clue. But it did fix the issues - all the cursor-related issues!

Try it.

We're now on high alert for when exactly the issue starts to resurface to try to pin down exact causes.

  • I know this is an old answer to an older post, but in April 2016 this still solved the problem. I didn't have an Adobe apps open, but uninstalling Adobe completely on Mac El Capitain, then reinstalling caused this issue. So Adobe is still causing this. Installing Smooth Mouse fixed it. – David Apr 26 '16 at 3:31
  • I had the problem today and this solution didn't solve my problem because I didn't have an Adobe app open. However, I opened Lightroom and then closed it again, and that resolved the issue. – Victor Engel Mar 13 at 19:14
  • Same here for me. It's 2018 and this issue still occurs. I do not have Adobe Photoshop running, but opening Photoshop and closing it immediately fixes this problem. – uzyn May 4 at 15:20

Hey I know this is an old issue. But I just recently was faced with it as well. The cursor did not change into a hand when hovering over links, plus my cursor was flickering and jumping in all Adobe Apps! I'm using OSX El Capitan.

My issues were solved by installing SmoothMouse. I don't even use any features of the App but it did overwrite some settings and now everything is working fine!

Hope that helps anyone.

  • SmoothMouse didn't fix it for me, but it seems like a nice utility anyway so I'm going to carry on using it for now. – fazy Aug 8 '16 at 7:14

Using SmoothMouse worked for me as well. It must overwrite some files. It worked immediately and has continued to work with no problems. http://smoothmouse.com/

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.