1

I've been on the Yosemite and noticed only as of just this morning that my screen was on with a screen saver running.

I have screen savers set to never start, and I have Display sleep set to 10 minutes under Energy Saver. I went away from my computer again today and came back to find the display on again with the screen saver on again. I realize I could have processes disrupting display sleep, but why would the screen saver come on if it's been told not to?

Is this some new Yosemite issue? How might I fix it?

  • You could use caffeine. It prevents your computer from going to sleep/displaying screensaver with a tiny applet shown in the top right menu bar. – woff Oct 18 '14 at 20:46
  • I'm not worried about sleep one way or another, but I do want the screen to go dark rather than running a screen saver, which is set to NEVER run. – UtopiaLtd Oct 18 '14 at 20:47
  • Alright then. Will do some research. – woff Oct 18 '14 at 20:47
  • I have a simular problem with Yosemite Server. All Saver/Sleep/EnergySaver is disabled but it still goes to sleep an stops Timemachine Services and kicks users uot from AFP File Sharing. Any ideas? I will test Caffeine tomorrow... Thanks, Mats Jansson, Sweden – Mats Jansson Sweden Feb 23 '15 at 22:54
1

I noticed the same effect in full Yosemite installation: screensaver starts when the computer (macbook air) is put down to sleep. If we add to this the battery "eating" behaviour I observed as well. I have unchecked every item that can use power, icloud and handsoff included, but the system itself needs a lot more energy than Mavericks. The general picture of power management seems to be worse than ever.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .