1

I have a problem in that any .sparsebundle I create in my home folder tree is not getting backed up to time machine.

It is like an 'exclude by path' but I can't remove it or see where it is defined.

# whoami
root
# tmutil isexcluded /Users/andy/atest.sparsebundle /Users/Administrator/atest.sparsebundle
[Excluded]  /Users/andy/atest.sparsebundle
[Included]  /Users/Administrator/atest.sparsebundle
# defaults read /Library/Preferences/com.apple.TimeMachine.plist ExcludeByPath
(
    "//Users/Shared/adi",
    "/Users/Shared/adi",
    "/Library/Application Support/Microsoft/PlayReady"
)
# ls -l@ /Users/andy/atest.sparsebundle
-rw-r--r-- 1 root staff 0 18 Oct 20:54 /Users/andy/atest.sparsebundle
# xattr -l /Users/andy/atest.sparsebundle
# rm /Users/andy/atest.sparsebundle
# tmutil isexcluded /Users/andy/atest.sparsebundle
[Excluded] /Users/andy/atest.sparsebundle

Any ideas?

  • Just stumbled on this. There is another list of standard Exclusions in /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.plist. Mine doesn't mention sparsebundle files though. Might be worth checking that file on your machine. – Alistair McMillan Oct 18 '14 at 18:59
1

Have you tried removing the exclusion with the tmutil command?

tmutil removeexclusion /Users/andy/atest.sparsebundle

  • Yes I have tried that many times. I think it is an exclusion with a named path somewhere because the tmutil isexcluded shows that any name (a file that doesn't even exist) is excluded if the name matches *.sparsebundle There is one file I have that matches that search that does get backed up, but any new ones I create don't – Andy T Oct 18 '14 at 18:45
  • Is it perhaps intentional? Is the system perhaps designed to only backup the contents of a sparsebundle when it is mounted? – Alistair McMillan Oct 18 '14 at 18:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .