It seems that Little Snitch 3.4.1 is a rehaul of the old version and this solution to disabling it in the guest account posted here Disable Little Snitch in guest account? doesn't work anymore.

When I get to step 4, there is no at.obdev.LittleSnitch.plist file. Additionally, it seems that when I disable LS in the guest account temporarily and then log out and log back into my regular account, it disables it for my own (admin) account as well. Everything I've tried isn't working and it's so annoying to be bombarded with little snitch prompts on the guest account. Does anyone have a solution?

3 Answers 3


You can limit access to specific apps via the Parental Controls in:

System Prefs > Users & Groups > Guest User

then click the Open Parental Controls. It may take some configuration to get all the services working. But I've logged into guest having disabled Little Snitch and it hasn't opened. It worked fine when I logged back into my account.

  • So unfortunately, this doesn't solve the problem of the user still getting bombarded with popups on startup. See this screenshot: cl.ly/Y6XJ Commented Oct 18, 2014 at 21:52
  • If thats not having the desired effect. You may be able to write a script using launchctl to stop little snitch when the guest account loads. This is a bit out of my area, maybe someone in Superuser could help?
    – kernelGinj
    Commented Oct 19, 2014 at 7:56

I am on Snow Leopard (10.6), and this solution has appeared to work for me:

Find the files


and set their permissions such that "everyone" has No Access, and any account or group that you want to have access to Little Snitch has at least Read access.

I don't know of any potential side effects, but this appears to disable it on the guest account while leaving it intact on my main account. You can probably extrapolate this to other accounts or groups.

Note that you will probably need to create a Little Snitch rule for webfilterproxyd to allow connections in order for the guest account to access the internet.

  • 1
    Thank you so very much for posting this. Could you explain a bit further how to set the permissions and also how to create the filter to allow web access for the guest account? Have you tried it yourself and had web access on the guest account despite disabling it? Thank you thank you thank you. I have hope again, haha. Commented Aug 20, 2015 at 3:58
  • Right click a folder or file -> Get Info. In the bottom of the box that pops up, you'll see a section for Sharing and Permissions. Set them there. You may need to click the padlock and enter an admin password to allow editing of permissions. It's likely that webfilterproxyd will just "pop up" in usual LS fashion. You'll just need to allow it after entering an admin password.
    – kmantel
    Commented Aug 29, 2015 at 7:01

It's because it is not an app it's a boot plugin runn by the system,

So there is (as far as I know ) no solution to that issue, if you don't want to reverse engineer MacOsX itself. That would be possible on Linux.

To solve the problem the only solution I found is to use the uninstall (in the installation disk image). But this remove it from all the computer .

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .