I recently upgraded to OS X Yosemite. Everything works fine but for some odd reason my cursor fails to highlight (provide feedback on anything I hover on any options).

As an example (if I'm not explaining this very well):

When I hover over the options in the Safari menu (or any other menu, nothing shows up as a blue background as you would expect (it only turns blue after I've clicked it).

I've been running Mavericks for a long while, and I had no issues.

I'm not sure if the mouse has a part to play, I'm using Mad Catz R.A.T3, anyone know if this as an issue with Yosemite? Or are aware of a fix?

7 Answers 7


I had the same issue with my Mad Catz MMO 7 and I fixed the problem! If you download the latest driver software from http://madcatz.com/downloads/ for Mavericks (OS X 10.9) it fixes the problem. You will have to restart your computer in the process.

  • Ah, I downloading the drivers, I forgot to restart. As soon as I did restart, the problem was resolved, thank you! Oct 19, 2014 at 11:58

I reached out to MadCatz support and they have a workaround to get the Mavericks drivers working in Yosemite:

Go to System Preferences -> Security & Privacy -> Privacy -> Unlock to make changes

In the list "Allow the apps below to control your computer" ticked the following:

  • MadCatzSmartTechnology
  • Mad Catz Editor”

For me the same with a Logitech MX connected to a unifying receiver. I did repair the mouse with the Unifying software provided by Logitech and then it worked again.

  • 3
    I've been fighting my mouse for 2 days, and this fixed it. To anyone else, by "repair" he means to unpair and pair again.
    – Joseph
    Jun 25, 2015 at 18:09
  • I ran into this issue when I had the Unifying receiver connected in addition to a wired mouse. Unplugging the receiver, then unplugging my wired mouse and plugging it back in, fixed this.
    – Aaron
    Feb 2, 2018 at 22:25

I have the same problem with Mad Catz R.A.T. 5. I haven't tried to fix it yet, but it appears that the driver is the cause of the problems.


For what it's worth, my mouse isn't compatible with the Macbook Air A1466...I'm using a Logitech M510. For the longest time, it worked flawlessy with my 2011 Macbook Pro. Switched my computer yesterday for work, and a large part of it's functionality ceased to work. Including the hover option.

  • Could you add what drivers if any you use with the mentioned mice? It seems a pointer is t just a pointer for hover functionality ...
    – bmike
    Sep 15, 2015 at 18:55

I'm having the same problem now in El Capitan with a RAT 3, and none of the above advice worked for me. I emailed their support and received the following reply (very quickly, to their credit):

Thank you for contacting the MadCatz Tech Support Team.

Please be advised that our developers are still working on a software for the most recent versions of the Mac operating systems.

Unfortunately, we cannot provide you with a time frame when this will be available.

What we can suggest is to use the device as a plug and play one or to ask for a refund if you have recently purchased it.

I am sorry I cannot assist you with this.

I guess I'll just put up with it and hope that a fix happens sometime. I'll comment here if I do get more information.


For me uninstall and install lastest Mad Catz RAT Driver 1.1.69 nothing changed. But when I delete MadCatz from Application and every file with name contain 'madcatz' from my drive and restart computer - hover function with my R.A.T. 9 work again. But sadly every time when I unplug my MacBook from Display problem appears again. When plug in Thunderbolt Display again to MacBook I must restart system.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .