2

I recently upgraded to Yosemite, enabled FileVault and foolishly enabled TRIM (had no idea it wasn't supported).

Upon restart, my machine gets the grey screen with the crossed-out circle of death.

After figuring out what happened, I then attempted to restore from a Time Machine backup (10.9). The backup failed almost immediately, but did manage to erase the HD (or at least the partition is gone).

Now I'm completely stuck. Disk Utility can see this drive, but cannot erase or re-partition it. The drive isn't mounted so I cannot access it with Terminal (at least with my level of knowledge). cd /Volumes/mydrive doesn't work - no such directory.

I have re-installed Yosemite on my second hard drive and booted from there. I tried Disk Utility again and I still have no options available to erase or partition my original disk, although it is there.

Can anyone help me get my original disk back into functioning form? If I can just get the disk erased and partitioned, I can load my Time Machine backup and be off to the races. Thanks!

  • Can you disable TRIM from your HD-booted system? ...& thanks for the heads-up, I'll make sure I don't enable it if/when I go to Yosemite – Tetsujin Oct 18 '14 at 11:16
  • btw, cd /Volumes etc will only work if the drive is mounted. The volume is gone, so the fix wouldn't work anyway. – Tetsujin Oct 18 '14 at 11:17
  • I can't access the drive from my booted system because it won't mount – timshutes Oct 18 '14 at 11:26
  • If trim enabler can see the device at all, that might free it up, after a reboot; maybe with reset SMC. – Tetsujin Oct 18 '14 at 11:30
  • I had the same problem, Disk Utility seemingly couldn't repartition the drive for reinstall, but I tried repeatedly and eventually it worked, so for anyone reading this, also try a couple of times (rebooting), trying verify/repair and such. – oarfish Nov 28 '14 at 17:43
3

A clean install is not necessary, you simply need to reconfigure your NVRAM (nvram boot-args=kext-dev-mode=1) to disable the kext signing requirement for OS X. (After which, you can remove your TRIM enabler and reverse this change or leave it until the next time your NVRAM is changed/resets)

A very clear explanation of OS X 10.10 Yosemite's new policy with Kernel Extension (kext) signing now being required from the creator of Trim Enabler, as well as simple steps to recover the grey boot screen after TRIM/Yosemite mishaps:

https://cindori.org/trim-enabler-and-yosemite/

  • I referenced the developer's solutions in my question. However, they were not helpful in my case. Also - the solution above didn't work because of the combination of enabling file vault, and the failed time machine backup - my disk drive was gone (no way to boot back into it after reconfiguring NVRAM). The solution I posted above was my only option. Although your answer may work well for other cases. – timshutes Dec 1 '14 at 15:19
  • +1: I gave a similar answer here. – n1000 Dec 25 '14 at 10:17
1

Finally figured this out. It was pretty simple in the end. Here is a summary of my problem and the solution.

  1. Installed Yosemite on my SSD
  2. Enabled Trim (oops!!)
  3. Rebooted and got grey screen with crossed out circle
  4. Rebooted into Recovery
  5. Tried Time Machine Backup, which failed
  6. Installed Yosemite on backup drive partition
  7. Couldn’t erase / partition original SSD with Disk Utility
  8. Erased and partitioned original SSD with Terminal (see below)
  9. Restored Time Machine Backup on original SSD
  10. Re-Installed Yosemite and did NOT enable TRIM

Here is the specific terminal command I used:

diskutil eraseDisk JHFS+ name disk0

Note – you can find your disk by using the following command: diskutil list – find your drive under “IDENTIFIER”

“name” is the name of your new drive.

Hope this helps someone!

0

Create a USB Install drive, and do a clean install.

http://www.macworld.com/article/2367748/how-to-make-a-bootable-os-x-10-10-yosemite-install-drive.html

  • I attempted that with a second hard drive. I can't reinstall because there are no longer any options to erase or partition the initial drive. On the partition tab, everything is greyed out. – timshutes Oct 18 '14 at 11:42
  • diskutil from Terminal? How about use a Windows/Linux to format the drive to FAT32, and go from there? – fartheraway Oct 18 '14 at 11:47
  • I'd rather avoid pulling the HD out as a last resort. I couldn't find the drive in terminal, but my knowledge is limited. – timshutes Oct 18 '14 at 11:57
  • You don't have to. Download and create a Ubuntu Install Drive and format the problem HD. – fartheraway Oct 18 '14 at 12:03
0

Having exactly the same problem, i fixed it using the advise and command mentioned above: diskutil eraseDisk JHFS+ name disk0

The tricky part in my case was that the name of my SSD was not listed doing diskutil list command so the command would not accept simply disk0 (disk0 was my SSD). I tried to use"unidentified" and it worked: diskutil eraseDisk JHFS+ unidentified disk0 erased the disk and made available for OSX installation.

-1

Same problem here. I have Macbook Pro, 15 inch, 2009 model. Was on Maverick, upgraded carefully (prepped and cleaned). Upgrade went fine, was able to use it a day, then no boot. I had installed an OWC SSD inside, put in a couple of years ago, and trim enabled. On trying to start, gray screen, no icon. Here is what I tried (along with help from Apple):

  1. Resetting pram.
  2. Resetting power manager.
  3. Starting with command/R to access recovery volume.
  4. Using external boot backup, USB port, and holding down option key.
  5. Attempting to access internet archive (not sure right word) by using command/option/R.
  6. Starting from an install disk in the optical drive.

None of this was successful. Every attempt resulted ONLY in a gray screen. Finally, giving up after trying the optical drive, restarted holding down the trackpad to eject the CD. This happened, disk came out, and suddenly the drive came to life again. I don't know if this was chance or somehow holding the trackpad down had an effect.

After the drive back again, I tried ALL the steps that Cindori suggested to inactivate trim and none of the steps had any effect whatsoever. So don't know if this is going to be a continuing problem or not as I can't inactivate trim. I did trash Trim Enabler and cleaned caches and did maintenance with Onyx so hopefully will not be a continuing problem.

In any case, has taken a few days to deal with so far.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.