I updated my MacBook 13″ mid-2012 from Mavericks to Yosemite and everything was perfect, until I recognized that I couldn't check my YouTube feed.

I tried again and again, but it didn't work.

I tried it with other DNS Servers like Norton Security Free-DNS or the Normal Google DNS, but nothing happened.

In the end, I tried to use the Google IP in my Browser, but that only worked always for one link.

Running the Ping - Google.com results in

cannot resolve google.com: unknown host

  • Could you open up Terminal, try the command "ping google.com" and tell us the IP address that comes back? That might help diagnose what is happening. – Alistair McMillan Oct 18 '14 at 9:26
  • It says ping: cannot resolve google.com: unknown host – Mania Craft Oct 18 '14 at 10:29
  • This might be bad! Check your /etc/hosts file. It might be that the problem is that google.com is rerouted to an unknown/malicious other ip. – CousinCocaine Oct 18 '14 at 18:02
  • I am experiencing the same exact problem after upgrading to Yosemite. Strangely, this affects only 2 of my 4 user accounts. – Donald Taylor Oct 21 '14 at 23:09

Assuming you've done this already but just to confirm. This will set you up to use Google's DNS service.

  1. Open the Network pane in System Preferences.
  2. Select the Network connection that is actually in use as indicated by the green dot.
  3. Click Advanced...
  4. Select the DNS tab.
  5. Enter the values from the below screenshot. Take note of anything that is already there under "DNS Servers:" and remove it.
  6. Click on OK to dismiss the Advanced panel and then Apply.

Then try pinging google.com again.

Screenshot of System Preferences set up to use Google DNS

| improve this answer | |

Post the contents of /etc/hosts

If you have anything regarding google.com there you should remove it.

| improve this answer | |
  • 1
    It says The same thing again Alistair – Mania Craft Oct 18 '14 at 11:24
  • Rafa, /etc/hosts??? – Mania Craft Oct 18 '14 at 11:24
  • Please elaborate this answer, i.e what is /ect/hosts,how to find and check it's contents and if as you suggest remove stuff how to safely do so. – markhunte Oct 18 '14 at 11:52
  • ## # Host Database # # localhost is used to configure the loopback interface # when the system is booting. Do not change this entry. ## ::1 localhost – Mania Craft Oct 18 '14 at 11:58
  • 1
    thx for help, but do you have a solution?! – Mania Craft Oct 18 '14 at 18:36

Not sure if its the same problem, but on an account with parental controls, upgraded from Mavericks from Yosemite, I can no longer access HTTPS (SSL) websites. I can access HTTP websites until I access a HTTPS website. Once an SSL website is attempted, all communication ceases.

I tried lots of combinations. I'm also running Little Snitch, but I disabled it. Other accounts work fine. Disabling parental controls did the trick.

Note that now-a-days, Google by default uses SSL for all its queries, even the home page redirects to https://google.com

| improve this answer | |

I had the same problem after upgrading to Mac 10.10 Yosemite. As a temporary workaround to this bug, you must disable Parental Controls on the problematic accounts.

If the problem still persists after removing the Parental Controls using Settings, you may need to take an extra step to be sure the managed account status has been cleared. Simply grant admin rights to the problem accounts and then revoke them. Admin accounts can't also be managed accounts so this clears any leftover settings.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .