0

After upgrading to the OSX Yosemite, Textmate's duplicate line command
ctrl+shift D produces an error warning: -K is specified; it is for 1.8 compatibility and may cause odd behavior.

Previously, this was fixed by changing the PATH to /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin

But now this does not work.

How can I fix this issue?

1

You can install Ruby 1.8.7 via rbenv and add it to Textmate paths:

PATH: /Users/YOUR_NAME/.rbenv/versions/1.8.7-p249/bin:/usr/bin:/bin:/usr/sbin:/sbin

TM_RUBY: /Users/YOUR_NAME/.rbenv/versions/1.8.7-p249/bin/ruby

If you have problems with installing ruby 1.8.7 with errors such as:

openssl_missing.h:68: error: conflicting types for 'HMAC_CTX_copy'

you can try to do brew unlink openssl. After successfully installing ruby you can link it back with brew link openssl --force

Good Luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .