11

After doing a standard, App Store upgrade of Yosemite it seems that the recovery partition is still Mavericks-specific. Whether I hold Cmd+R or Option and select the recovery partition it takes me to the Mavericks recovery. If I choose Reinstall OS X it kicks off the Mavericks (re)install screens.

Shouldn't there be a Yosemite recovery partition that replaced this? Is there any way to manually create the partition? Is this just how it's supposed to be with a Mavericks recovery partition after a Yosemite upgrade?

9

I had the same issue since the beta and the official release did not solve this issue. In the terminal I had the following output:

diskutil list

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            210.0 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
   4:       Microsoft Basic Data BOOTCAMP                40.1 GB    disk0s4

a recovery partition was available (but not working)

The following did fix my issue:

  • downloaded the yosemite installer (again)
  • created a bootable installation (8GB USB) drive with yosemite (USB drive volume name is Untitled).

sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction

  • Removing the not working recovery partition

diskutil eraseVolume HFS+ ErasedDisk /dev/disk0s3

  • merging the free space with the Macintosh HD partition

diskutil mergePartitions HFS+ MacHD disk0s2 disk0s3

  • Install (like you upgrade) Yosemite over your existing (Yosemite) installation and complete the installation procedure (I used the installer from the fresh created USB).

After the installation was completed I rebooted the machine and I was able to use the find my Mac option again (error related to the recovery partition was gone).

This worked for me, a small (typing) error might result in loosing your installation + data. Please be sure you have a good working backup before you start!

Used resource: removing-and-rebuilding-a-malfunctioning-recover-hd-partition/

  • Great solution and very close to what worked for me. I took it a step further and wiped everything and did a fresh install but knowing that you can create the partition manually is FANTASTIC. Wish I would've seen this before scorched the earth. One problem with my partitions was that there was (in order): Macintosh HD, Recovery Partition (10.9), Bootcamp, and some weird 109134812714-looking partition. Because the new one wasn't sequentially close to the other Mac stuff I don't think I could have merged it. – Michael Thompson Oct 20 '14 at 18:46
5

Are you aware of this thread at Apple Support Communities? https://discussions.apple.com/thread/6601122

According to this, Yosemite changed the way the Recovery Partition works when you have Core Volumes. It no longer shows in the list of drives when you boot with the option key pressed. The way to do it is by pressing Command-R.

I don't have Fusion Drive and still all my Macs ended up with Core Volumes after Yosemite Install and without Recovery HD showing up. Even after erasing, merging and reinstalling I ended up with Core Volume and no Recovery HD in boot options.

Command-R works.

Perhaps with Yosemite, you always end up with Core Volume?

If so, Apple should do a better job in communicating the change.

  • 1
    Even with cmd+r I was taken to the old 10.9 recovery partition. I had no way of getting to a Yosemite recovery partition. – Michael Thompson Oct 22 '14 at 15:23
  • This is the correct answer for users who have the proper partition set up. You just access it differently. @michael, you might need to do the accepted answer method :P – Chris J Dec 11 '14 at 0:50
1

When you use the recovery option to reinstall OS X it is supposed to download and install the most recent version of OS X previously installed on this computer to perform the install. The install image isn't stored on your machine.

This is why Apple specify that you need an Internet connection to perform a recovery install.

In order to reinstall OS X, you need to be connected to the Internet over an Ethernet or Wi-Fi network.

I'm guessing the reason you are getting the Mavericks installer is because something went wrong with your previous install (given that you're trying to use Recovery then I'm guessing something went wrong). Essentially it is trying to install the "Last Known Good" (to steal a phrase from Windows) version of the OS.

  • I'm using Yosemite without issue. I just wanted to run a permissions check through the recovery partition and (maybe) a disk check to make sure there weren't any issues. Edit: to be clear there seem to be zero Yosemite issues. It's working great! Just was poking around and thought it was odd that the recovery partition wasn't updated. – Michael Thompson Oct 17 '14 at 18:28
  • Ah. I think you can do both while logged into the live system. It just won't be able to fix any problems until you boot from recovery or another drive. – Alistair McMillan Oct 17 '14 at 18:30
  • Would it be worth (re)installing Yosemite on top of Yosemite to see if it fixes things or should I maybe do a fresh install? I've got full backups of everything multiple times over and I'd just like Yosemite to work as intended. – Michael Thompson Oct 17 '14 at 18:37
  • Fixes what? The recovery partition? – Alistair McMillan Oct 17 '14 at 18:40
  • Yes. I would really like to have a Yosemite recovery partition with Yosemite. – Michael Thompson Oct 17 '14 at 18:43
0

Last time I was surprised how easy it was to restore the recovery partition using Carbon Copy Cloner (CCC). Basically all you need is a intact recovery partition on an external disk. If you don't have that simply install OSX onto an USB drive. Then CCC lets you clone it onto your main drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .