3

I have an LG 34UM95 connected via TB on a Late 2012 mac mini.

After the Yosemite install, I no longer have the option of choosing 3440x1440 resolution in the Displays preferences. It worked just fine prior to the upgrade.

I did do the Option->Scaled bit to see the extended list of choices, but nothing higher than 2560x1080 shows up.

Can I get my 3440x1440 resolution back?

EDIT: my colorsync profile...

enter image description here


EDIT 2 I just upgraded from 10.10 to 10.10.2. Resolution stayed the same! Woot!! So, either the new update fixed the issue, or it didn't touch the graphics extension.

3

A bit of a late answer, but this issue is now fixed in Yosemite 10.10.2 - full 3440x1400 (on a macbook air you have to close the lid of your laptop, but it works without hacks!)

| improve this answer | |
  • I hope you're right. I'd been avoiding updates. I'll check it out. I'm running it on a MacMini though, not a macbook. We'll see ;) – JoshP Jan 29 '15 at 21:30
  • I just upgraded from 10.10 to 10.10.2. Resolution stayed the same! Woot!! So, either the new update fixed the issue, or it didn't touch the graphics extension. – JoshP Jan 31 '15 at 0:18
  • yeah, I thought the same, my gf has a mb air, fresh upgrade from mountain lion to 10.10.2, never had the hack, ill test in the morning and see if its actually fixed – Jonathan Jan 31 '15 at 0:23
1

I was successful in getting the 3440x1440 resolution back in Yosemite by following the instructions from a discussion on Apple's discussion page.

The thread is a good read, to put the instructions in context, but the gist is as such...

  • Disable the kext signature check sudo nvram boot-args=kext-dev-mode=1
  • Pull in the AppleIntelFramebufferCapri.kext from TimeMachine prior to the Yosemite upgrade
  • Make the small edit as described in the thread above (not going to copy/paste his post verbatim here)
  • Reboot

Success!!

I had the 3440x1440 resolution in my Display preferences right away. Didn't even have to hold down Option to see it.


Broken again after 10.10.1 update...

Looking to see if the same fix can still work...

| improve this answer | |
  • Let's just hope this isn't broken the instant there's a software update ;) – JoshP Oct 18 '14 at 13:37
  • crud... c'est la vie – JoshP Nov 18 '14 at 3:16
0

There seems to be a solute - see:

https://discussions.apple.com/thread/6240037?tstart=0

| improve this answer | |
  • That may not work in Yosemite, as Apple seems to no longer allow unsigned or modified kexts – Tetsujin Oct 18 '14 at 11:38
  • 1
    I saw that. Checking into it. I also started a thread similar to this over there. There may be some progress there too... discussions.apple.com/thread/6600759?start=15&tstart=0 – JoshP Oct 18 '14 at 12:56
  • @JoshP thanks for the kext, saved me digging about in time machine :D – Jonathan Oct 19 '14 at 14:12
-1

Just press the option key while you select "Scaled" and will appear all the compatible resolutions.

| improve this answer | |
  • the OP's question already said that doesn't work. – Tetsujin Dec 19 '14 at 16:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .