9

After upgrading my Macbook Pro to Yosemite, the volume icon at the top right is greyed out and sound does not work.

How can I fix this issue?

18

This can be caused by the default sound settings being changed. If you go to System Preferences --> Sound --> "Sound Effects" you will see a pull down list labeled Play sound effects through... On my machine there was the following listed: Internal Speakers and my monitor.

For some reason after the OS upgrade my monitor (and HDMI) was selected instead of internal speakers. Switching to Internal Speakers fixed this. You should select the appropriate item for your setup. Also, you can go to the Output and Input tabs and verify that the correct item is selected as well. See this picture for additional information:

enter image description here

3

I had to open Sound Preferences, change to Output tab, and select "Internal Speakers".

enter image description here

  • This worked for me also - I had my laptop closed and connected to a external monitor via HDMI - hence I assume that is why Yosemite may have selected the HDMI as the sound output? – ryan Dec 31 '14 at 1:13
1

I had the same problem. It turned out that I had my external screen plugged in while I ran the update so the sound was defaulting to HDMI out rather than internal sound or bluetooth.

Went to sound preferences, changed it and it worked.

  • Yep, this changed for me too - my HDMI screen had never been recognized as a sound device until I upgraded to Yosemite. It took me a while to figure out that it was now the sound device because the volume on the monitor was at zero! – Steve Eisner Oct 19 '14 at 8:59
0

Same problem here, disabled sound control. According to this post you can run

sudo killall coreaudiod

in Terminal for a temporary fix.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .