After a lot of searching on the internet I have been unable to find a solution to my problem. There are many people having similar problems, but no solution seems to work for me.

I have a 2013 MacBook Pro and I have a Toshiba 2TB External drive which I have used for the past 5 or 6 months to keep copies of my iPhoto Library and my Time Machine backups on. Everything has been fine up until yesterday. I plugged the drive into the USB slot to find it no longer appeared on the desktop. I have tried everything I can think of to get this to work. Here is a rundown of the situation:-

  • I have tried both USB ports on the Macbook.

  • The drive doesn't appear in Disk Utility or System Profiler.

  • I have bought a new USB cable.

  • The drive has it's own power supply and lights up and makes regular noises when on.

  • I have connected it to a PC and managed to access the files using HFSExplorer, which leads me to believe the HDD is okay.

  • I can browse both partitions and extract files to my PC using HFSExplorer.

  • The drive shows up in Disk Manager on Windows and shows the partitions.

  • I have another external drive, my old MacBook HDD in a caddy, which works perfectly, so I don't think its the USB ports either.

This is what I get in Terminal:-

-laeO@ /Volumes
total 24
drwxrwxrwt@  4 root           admin  hidden  136 17 Oct 13:36 .
    com.apple.FinderInfo      32 
 0: group:everyone deny add_file,add_subdirectory,directory_inherit,only_inherit
drwxr-xr-x  32 root           wheel  -      1156 17 Oct 12:18 ..
-rw-r--r--@  1 rebeccaholmes  admin  -      6148  7 Dec  2013 .DS_Store
    com.apple.FinderInfo      32 
lrwxr-xr-x   1 root           admin  -         1 17 Oct 12:54 Macintosh HD -> /

It really is bizarre. I am left thinking my only solution is to go through the arduous process of copying all the files to my windows PC and reformatting the HDD :(

Does anyone have a better solution to this problem?

Edit - Since posting I have also tried resetting the MacBook PRAM and SMC. Neither has made any difference.

Edit - Using DiskUtiliy after entering "defaults write com.apple.DiskUtility DUDebugMenuEnabled 1" command lists no external drive.

   "diskutil info disk1s2" returns the message "cannot find disk"
  • It happened to me sometimes with different drives, I found that powering the drive on before connecting the USB to solve the problem Oct 17 '14 at 13:28
  • Thank you for replying. I have tried plugging in the drive without the USB connected, however, the drive doesn't do anything until the USB cable is connected. There are no sounds from the drive or lights until I connect the USB to my MacBook. Then it sounds like it is booting up but the MacBook doesn't detect it at any level. Oct 21 '14 at 19:51
  • What's the exact product name of the external drive?
    – klanomath
    Oct 21 '14 at 20:38
  • The drive is a Toshiba Canvio Desk 3.5" 2TB USB 3.0 External HDD toshiba.co.uk/hard-drives/desktop/canvio-desk/hdwc120ek3j1 Oct 23 '14 at 15:27
  1. Please quit Disk Utility if it is open and launch Terminal in the folder Applications/Utilities/ with your external drive connected
  2. Enter the following command at the Terminal prompt:

    defaults write com.apple.DiskUtility DUDebugMenuEnabled 1
  3. Press Enter

  4. Quit Terminal
  5. Start Disk Utility and enable 'Show every Partition' in the Debug menu
  6. After a few seconds all partitions should be visible
  7. Mount the partition 'NameOfTheMainPartitionExternalHD' if it is present and greyed out with the blue button Mount. The partition should now be visible on your desktop.

    In the above example the external drive is an SD card and the usually visible partition of the external drive is gDisk. Don't touch disk1s1 (Lion) or EFI (Mavericks)

  8. Please check the format of the partition

  9. If the format is 'Mac OS Extended' you might check the drive for inconsistencies.

  • if the above answer doesn't work please enter in the Terminal.app: "diskutil list" and probably "diskutil info disk1s2" (disk1 should be your (only) external disk, disk1s1 is the efi partition of this disk and disk1s2 is your missing partition) and add the output to your question
    – klanomath
    Oct 25 '14 at 11:15
  • I have tried the "defaults write com.apple.DiskUtility DUDebugMenuEnabled 1" command today, but the drive still doesn't show up. It only shows my main HDD with 'Macintosh HD', 'EFI' and 'Recovery HD', there is no external drive showing. When I use the "diskutil list" it doesn't show, and "diskutil info disk1s2" gives the message "could not find disk". Oct 27 '14 at 10:52
  • I've replaced your screenshots with English UI—feel free to revert if I've lost the intent.
    – grg
    Oct 27 '14 at 12:11
  • @grgarside It's fine and consistent now. Usually i try to create screenshots of the english UI inside a OS X VM which didn't work properly...
    – klanomath
    Oct 27 '14 at 12:37

I have finally solved the issue I was having with the drive and it nows shows up on my Mac desktop :)

I installed Paragon HFS+ on my Windows 7 machine (it wasn't recognised on Windows 8 either). Then I copied all of my files to the PC hard drive so I could format the external drive.

Once my files were safe, this is what I did;

  1. I deleted my Parallels folder to remove any pc files.

  2. I deleted the .apdisk file.

  3. I deleted the .ds_store file.

After researching what the .apdisk and .ds_store files were, I thought I would give it a try, and it worked. I think something in these files was corrupt.

My drive works fine now, all of my files are still on it so no formatting was required.

I hope this helps anyone having similar issues.

Thank you to all who replied for your suggestions.


I also had the exact same problem with a Toshiba Canvio 3 TB and my Macbook Pro Mac OS X Mavericks; and the hard drive would appear on another Mac.

The solution was to delete the ".disk_label" and ".disk_label_2x" files in the hard drive root - actually I just moved the two files to a temporary folder to check. I did this on the other Mac.

Now the hard drive appears again. I don't know why this works.


Connect the drive to Windows machine and go to that folder in the Windows explorer and then right click in empty space and then select open command window here.

Then run the following commands

del /s /q /f /a .DS_STORE del /s /q /f /a ._.*

Run this command only and only if you are sure that you don't have any important files starting with "._" I had such files in the skype chat history and unfortunately I have lost those.

del /s /q /f /a ._*


Thank you so much for the answer as you have explained I have done the same things and now I recovered the hard-drive without formatting.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .