I just upgraded to Yosemite today and found that mirroring my laptop to my apple TV is very stuttery... It's not lagging but every second there's a slight delay, both audio and video.

Anybody else encounter this? I was messing with my router a bit today unfortunately so I'm not sure if this is a Yosemite issue or not...

Anyone know what I can try to fix it?

Edit: MBPr Late 2013, ATV 3

  • Might it be possible your AppleTV is on wifi and your network is under stress due to downloads and updates? Oct 17, 2014 at 9:38
  • No nothing all good there but it's not like it's lagging it's a very regular delay which is strange...
    – doovers
    Oct 17, 2014 at 9:40
  • It might be due to the change the way AirPlay works in iOS 8 and Yosemite, by adding peer-to-peer, the same protocol which it used in AirDrop to share files. Oct 17, 2014 at 9:45
  • Any idea what I could try to fix it?
    – doovers
    Oct 17, 2014 at 9:56
  • Nope, when I do, I'll post it as an answer. Sorry. Oct 17, 2014 at 11:05

1 Answer 1


A possible workaround for the airplay/wifi issues is to use the following terminal command

sudo ifconfig awdl0 down

This will disable AWDL & Airdrop but will allow you to have bluetooth on with airplay...

sudo ifconfig awdl0 up

will re-enable.

Credit to Mario Ciabarra who detailed the problem and solution in his blog post.

Another workaround that may be of benefit to some is to make sure ATV software is up to date, and then switch off bluetooth while using Airplay. This resolves the problem for me.

Also, I seem to get best results when in extended desktop mode instead of mirrored although I haven't tested it really. This was definitely the case in Mavericks.

Hope that helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .