4

My installation of the Mac App Store on Mavericks is broken. What alternatives are there for installing the new OS?

  • Did you solve your problem? If not which kind of Mac do you have exactly? – klanomath Oct 21 '14 at 22:59
  • I tried using the recovery function, but it said "Could not find installation information for this machine." (I don't understand why.) I got a Yosemite image from a friend and could not install it, I got the same error message and could not create a bootable drive. Another image resulted in other error codes while trying to install (could not open the image). I managed to create a bootable usb stick and installed it then. My MAS application is still broken and there are glitches everywhere. I have never been that frustrated in a decade of Mac usage. – lejonet Oct 22 '14 at 20:47
  • i think your backup (apple.stackexchange.com/questions/147942/…) was/is hosed and as a result your recovered system is. i will write a detailed answer in about 12 hours. – klanomath Oct 22 '14 at 22:13
  • What' s your Mac model and which kind of backup app/method do you use (time machine, ccc...)? – klanomath Oct 23 '14 at 9:22
  • I am using a Mid-2010 MBP and create backups using SuperDuper! – lejonet Oct 23 '14 at 17:56
3

My MAS application is still broken and there are glitches everywhere.

Looks like FUBAR BUNDY!

I recommend a clean install.

  1. Backup any additional files which aren't already in your SuperDuper! image. Probably it's faster to just backup/copy your or all user folder(s) to an external drive.
  2. Please check your hardware with your original system DVD (Apple Support: de_DE en_US) or if the DVD is not available with the appropriate Apple Hardware Test image.
  3. Do a SMC-reset (Apple Support: de-DE en-US)
  4. Do a PRAM-reset (Apple Support: de_DE en_US)
  5. Since your recovery volume is probably corrupted, you have to initiate an internet recovery by restarting your mac and pressing alt cmd R.
    The prerequisites for an internet recovery are listed here: supported Pre Lion Macs and Recovery/Internet Recovery. In a few words you need the latest firmware update installed, either ethernet or WLAN (WPA/WPA2) and a router with DHCP activated for a successful internet recovery.
    On a 50 Mbps-line it takes about 4 min (presenting a small animated globe) to boot into the recovery netboot image which is loaded from an apple server.
    (Additionally you might need an external drive or a thumb drive with at least 32 GB if you want to install to an external disk.)
  6. In the opening window choose Disk Utility and format/partition the drive you want to install the system to. Choose Mac OS Extended (Journaled) and GUID partition table (available with the option button). Quit Disk Utility.
  7. Choose Reinstall OS X and Continue. After some verification steps you will be asked to choose a partition for the new system. Continue until the system is installed. Depending on your internet connection it might take several hours to download and install 5.5 GB. If you get a message like 'Could not find installation information for this machine' just restart your Mac and continue with step 5. (The netboot image seems to be very picky with the WLAN connection and it took me two attempts to get around this step)
  8. Set up your new system.
  9. Start App Store.app and log into your Apple Store account.
  10. Download and install Yosemite if it wasn't already installed in step 7 or just download it and quit the installer to get the Yosemite installation app for any further use.
  • I did as you proposed (except the Hardware Test resulted in just another error, not a hardware error but an error running the AHT …) and got a running Yosemite installation. I imported my saved user profile again and re-imported also the broken MAS application. – lejonet Nov 1 '14 at 9:58
  • "...and re-imported also the broken MAS application." Why that? The Yosemite installation already has an App Store.app. Or it got broken by importing your user folder? – klanomath Nov 1 '14 at 10:07
  • I used the migration assistant, what was imported ruined the MAS application again. – lejonet Nov 1 '14 at 10:48
  • Did you migrate just your user data or also 'Applications'? And from where? SuperDuper, Time Machine or just your user folder on a 2nd disk? – klanomath Nov 1 '14 at 10:53
  • I migrated user data and applications from a SD backup. Just now I did the following: I created another user and used the MAS there to update my applications. So there must be something corrupt in the settings and other files that come along with the MAS application on my account, not the application itself. – lejonet Nov 1 '14 at 11:34
0
  1. Grab an Install OS X Mavericks.app
  2. Install the OS onto a USB drive as if it's a dual-booting system.
  3. Start up the OS from USB drive, download OS X Yosemite.
  • What do you mean by "grab an Install OS X Mavericks.app"? If I don't have the installer anymore and can't download it because of the broken MAS I am in the same situation. – lejonet Oct 17 '14 at 10:42
  • Use Recovery Mode to install a clean copy to USB drive, then. – fartheraway Oct 17 '14 at 11:05
0

You could boot to the Recovery HD or Internet Recovery and install OS X to a USB drive. Then download and install Yosemite. Notice that older computers do not support this option.

You must log in to answer this question.

protected by bmike Nov 18 '16 at 0:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .