9

Since using Yosemite, I've had the annoying problem of my current Terminal window flashing when backspacing on an empty line. I know on previous versions of OS X this flashing was not default, and could be toggled in accessibility settings, but I cannot find the same setting and I'm dying to get this turned off. Any known ways to get rid of it?

12

That is called the visual bell, and by default it’s enabled when your sound is muted. To change that setting, go into Terminal > Preferences > Profiles > <your profile> > Advanced.

screenshot of prefpane

You can also run

echo $'\nset bell-style off' >> ~/.inputrc

to disable Readline's use of the bell (deleting on an empty line, tab-complete, etc.). You will need to restart your session for this change to take effect.

  • 1
    good job bro!!! – Soheil Dec 1 '14 at 1:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .