4

Recently I updated album covers in most of my mp3s, but their respective thumbnails on Finder did not get updated.

Things I tried:

  • Removed (rm ~/Library/Preferences/com.apple.finder.plist) without solving the issue at all
  • "touch"(ed) the files, which refreshed some - not all - the thumbnails

Any ideas on how to force a refresh of my mp3 thumbnail icons in Finder?

See the manifestation of this issue below:

enter image description here

  • Thumbnails are generated by QuickLook. You can reset its cache by typing qlmanage -r cache. If this didn't work reset it completly with qlmanage -r – Mateusz Szlosek Oct 16 '14 at 10:58
  • @MateuszSzlosek: You should submit this as an answer. – CousinCocaine Oct 16 '14 at 10:59
  • @CousinCocaine I've posted this as an answer now. I'm not sure if it helps, that's why I posted a comment. – Mateusz Szlosek Oct 16 '14 at 11:01
  • Nice. Although the question is form the OP, your post can help others as well. It might not be the right answer to this problem for the OP, it is an answer to the problem. – CousinCocaine Oct 16 '14 at 11:27
  • Do these .mp3 files have cover art? If not, no thumb will be created, ever. iTunes might put these in the 'same' album and only use the coverart of the first song. Are your really sure there is cover-art? – CousinCocaine Oct 22 '14 at 21:34
10

Thumbnails are generated by QuickLook. You can reset its cache by typing qlmanage -r cache.

If this didn't work reset it completly with qlmanage -r.

  • Unfortunately it didn't force the thumbnails to update. Any other ideas? – Pomario Oct 16 '14 at 20:30
1

A combination of the previous answers worked on my MacBook Pro (mid 2012) running 10.13.6:

In Terminal:

qlmanage -r cache # qlmanage: call reset on cache

qlmanage -r # qlmanage: resetting quicklookd

Then: [Apple] > force quit > select Finder > relaunch

After a few seconds, this refreshed the .png and .jpg thumbnails on my desktop. I don't have .mp3s there so I can't speak to that.

1

To refresh icons go to target folder (like cd /home/John/music/nocovers/ or cd ~/music/nocovers/ whatever - they mean the same for user John assuming /home/John/music/nocovers/ your target directory) in the Terminal and there execute:

qlmanage -p .

Should do the job.

0

Option Right Click on Finder in the Dock.

Click Relaunch.

It should refresh the thumbnail icons. For sure this worked for images that I rotated with xnview.

0

Check if the mp3 really have an artwork with some tag editor like https://itunes.apple.com/it/app/tag-editor-free/id984278082?mt=12

If there is maybe just try to re-add the artwork with the tag editor instead with itunes.. if you can see the icon now on finder so is itunes related issue and maybe the random I-heard-somebody-say is the right direction ;)

-1

I found this thread on the Apple forum where one guy said he had the same problem as you with Finder not showing the cover art on MP3 icons. He said he fixed the problem by going into iTunes and deleting all his Voice Memos (apparently you have to delete them from both the Playlist and Genre sections in iTunes) and then restarting iTunes. A bunch of people replied to him saying that solved the problem for them as well. If you need your voice memos then back them up to a different location before you delete them from iTunes.

  • This is the kind of random I-heard-somebody-say answer that is more typical of those very Apple forums that bring me to StackExchange. If you haven't tested a solution or have it on very good authority, please don't pass on random rumors. – Wes Modes May 28 '17 at 18:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .