5

In my office we have two Airport Express routers both acting as access points (no DHCP). They both broadcast the same wifi network (same name).

Now, the one I'm sitting right next to was setup later than the first one, due to bad reception from the first one.

Now my problem is, that even though I'm sitting right next to the new one, my computer keeps connecting to the first one with the bad reception. I have tried removing the network and re-add it again, but it still connects to the one with bad reception.

How can this be, and how do I solve it, without changing the network names and manually choosing which one I want to connect to.

Here is an image of the situation

My question is btw. somehow similar to this I think: Connect Mac to closer Access Point

  • I find the turning off and on WiFi on my device will often cause the device to connect with the stronger signal and maintain it. – sdmeyers Oct 16 '14 at 14:27
  • I have seen the same behavior, it's just not persistent – Niels Kristian Oct 16 '14 at 15:11
2

With your setup of multiple access points sharing the same SSID (network name), your wifi client will use its built-in roaming algorithm to switch. But even if you have a marginal signal (i.e. one bar) on the one that's farther away, most times, the wifi client will stick to that access point, simply because it was the first one configured. To get around this you have two options...

  1. Use different SSID's, and in the Advanced section in Network Preferences/Wi-Fi, drag/drop them in the preferred order. The good thing about this is the ability to quickly see which one you're connected to at any time and explicitly switch over whenever you want.

  2. If you must have the same SSID... Change the SSID for the closer (desired) access point to a new name (e.g. "NewName"), re-associate your computer to that access point with the new name, then change SSID for the older access point to the same new name.

  • That's what I suspected. It's just a little crazy I think that I cannot reprogram this behavior. Are we sure that there is no way to reset/change this behavior? And BTW. not very smart algorithm, apple should change that right? – Niels Kristian Oct 16 '14 at 9:59
  • 1
    Is this really the solution. I have this problem with my macbook not with my iphones. Only at home and not at work, where also multiple access points are active with the same SSID. My imac at home is at one solid location and therefor not tested. But can i aspect the same problem? My macbook at home won't even connect to the router (when multiple access points with the same SSID are active). I hope more people give threir experiences. – Harm Jan 31 '15 at 18:59
  • 1
    Check the answers to this similar question: apple.stackexchange.com/questions/66919/… – dunxd Apr 6 '15 at 0:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .