1

I have a problem with my MAC. Yesterday it got stuck while it was trying to connect to a Wi-Fi network, then, since it didn't respond I decided to turn it off using the power on/off button ('). When I restart it, MAC didn't mount my disk0s2 where OS X is installed (Macintosh HD) and where all my files and programs are stored, instead the OS X Utility appeared.

I tried to verify the disk using Disk Utility and the Terminal by running:

fsck_hfs -fy /dev/disk0s2 
//(disk0s2 it's the device file for my Macintosh HD Volume, I have checked this with diskutil list)

but I got this message:

Invalid content in journal 
** Checking Journaled HFS Plus Volume
Invalid record count
** The volume cannot be verified completely.

I thought I need to disable the journal on the volume, but even after this command:

/System/Library/Filesystems/hfs.fs/hfs.util -N /dev/disk0s2 
disable_journaling: /dev/disk0s2 is not journaled.

If I run again fsck_hfs I get the previous error "Invalid content in journal" again and again.

If, using Disk Utils, I click on the "Repair Disk" button, I get this:

The disk cannot be repaired. Backup how much as possible files, format the disk and restore your files.

But I do not have a backup disk (I know I know, I should or better I must had one), but I don't. How can I backup how much as possible files if I cannot mount the disk and navigate through the file system?

Why I keep obtaining the journal error even if I have disable it with hfs.util?

Is there a way to access my data again using embedded tools and not using commercial solutions like Tech Tools or Disk Warrior (I have read about these two around in forums)?

Another thing I have noticed is this: If I start the MAC in single user mode (command line interface) and I type "exit", I get the following error while the MAC is trying to boot:

hfs_mount: hfs_mountfs returned error=5 for device /dev/disk0s2 

How should I interpret this error?

Please, if you came across this or a similar problem, post what you did in order to resolve this annoying problem (I also used and still use Linux (Ubuntu) and I never had such a problem when the system got stuck and I pressed the power off button in order to turn-off the hanged system).

Thanks for the attention.

  • 1
    Your computer wouldn't happen to be a 13" MBP, mid-2011 to mid-2013-ish era, would it? Those have had a ton of problems with the hard drive cable, which is much nicer than the hard drive. – Hawken Rives Nov 19 '14 at 5:19
  • Thanks for the response, I have used prosoft data rescue, recovered my data and reinstall, after trying without success with DiskWarrior. – user3019105 Nov 19 '14 at 6:22
-1

Open error 5: youre I/O is corrupt. Hardisk is probably failing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .