I keep getting hundreds of these "Could not synchronize record: [...]" errors, but the meetings and emails refered to in the Errors panel do not exist - I deleted them, and confirmed that they are not in any folder, calendar, or anywhere.

They say error number: 19759

E.g.: enter image description here

  • 1
    Thank you, Matt! These errors have been driving me nuts, and nothing I tried (clearing the cache, deleting the meeting, etc.) worked…until I followed your suggestion to permanently delete all of the meeting invitations from my Trash folder. – user141875 Aug 17 '15 at 14:39

It turns out that these meetings were still on the hard drive. I went to Finder, searched on the title of the meetings (which was in the Error message itself), and simply deleted the files in question. They were kind of "grayed out", which led me to believe they were either owned by another user or had failed to get deleted correctly.

  • Thanks for the solution. Note, I also emptied my trash just in case, but my MS Database Utility needed to rebuild my Outlook identity (all sounds very technical but the identity rebuilding was automatic and seamless). – user118314 Mar 16 '15 at 9:33
  • 1
    This solution worked for me. Detail: the message doesn't put the email subject within quotes, so when you surch for it on Finder, please remove the generic message parts from Outlook. Could not synchronize record: **<My email subject here>** to Exchange server – Ricardo Jul 10 '15 at 23:09
  • It worked for email issue too. – Ricardo Jul 10 '15 at 23:17
  • Is it safe to delete any of these? If I delete one it's not having trouble with, will it come back at the next sync? I should add that mine don't appear to be grayed out. – KC Baltz Jun 23 '16 at 16:57

Seems like I have resolved the issue, by right clicking on the folder that was having issues (my Drafts folder), selecting "Properties" and under "General" clicking "Empty Cache"

  • This fixed the issue (with a recurring calendar item) for me in Outlook for Mac version 15.39. Thanks. – jamesnotjim Oct 26 '17 at 20:02
  • FYI to get to the "Empty Cache" button for calendars: go to calendar tab, under My Calendars, right click each calendar and you will see the same "Properties" menu mentioned above. – yellavon Jun 10 '19 at 16:10
  • This did the trick for me too, thanks! – Leonardo Pessoa Mar 15 at 23:00

I fixed my issue by searching for the email thread in my trash and sent items. Deleted all instances and the error went away. My issue was in Outlook 2014, but I've had the same issue in 2011 before too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .