2

Since upgrading to iOS8, I've had constant problems with the Calendar app. First it started only syncing to the iCloud, and ignored everything from Exchange. I managed to stop this, and "delete all" entries from the Calendar, but no it isn't doing anything at all. The + symbol to create a new event is grayed out. I checked the settings, and Exchange is the default account. How do I get this working again?

  • I even tried wiping the phone and restoring from backup, but of course the problem still exists. I would have restored it back to iOS 7, but that backup is long gone (since iTunes seems to only keep one revision back in backups). – Darren Oct 16 '14 at 2:11
  • Please mark an answer if one worked. Also, at this time 8.1.2 is a stable build and has had a number of Exchange fixes since the initial release of iOS 8. – james_fuller Jan 2 '15 at 20:24
  • There is nothing simple about this problem. My issue is that any calendar event created IN iPhone (I have 6+) does not migrate to my Exchange or my Macbook air. I can delete from iPhone and it will sync, just never create. I have done everything suggested above including wiping out the account and re-entering...nothing works. Very frustrating!! – user108723 Jan 7 '15 at 16:25
  • Are tou sure you where using the right calendar? When creating a new item make sure to select the right calendar. Perhaps this is your problem. – Jules Jan 7 '15 at 17:17
1

If you have not already tried it, deleting the Exchange account from the iDevice (and all of the associated contacts, calendars and email if any was being synced), and then recreating the account can sometimes fix a variety of errors. Of course, making sure you know all of the server names and passwords and other needed information to set up the account would be wise before deleting the account.

1

It's simpler than that.

  • Goto Settings> Mail > Exchange
  • Calendars

    Just switch off calendar and switch back on. It will sync automatically.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .