8

I bought my iPhone 6 Plus in Dubai. I am using the phone in Sri Lanka and I cannot use the FaceTime. How can I use FaceTime while in Sri Lanka?

8

Sorry, Facetime is not available on devices purchased in the United Arab Emirates and therefore in Dubai, as stated in these KB articles:

  1. http://support.apple.com/kb/TS3367

    FaceTime might not be available, or might become unavailable, on devices purchased or used in certain countries, including Saudi Arabia and the United Arab Emirates.

  2. http://support.apple.com/kb/ht1937 enter image description here

I recommend that you contact Apple support in Sri Lanka at http://www.apple.com/lk/support/contact/ or a local Apple reseller, they may be able to help you.

To find a reseller near you visit https://locate.apple.com/lk/en/sales/?pt=all&lat=6.9270786&lon=79.86124300000006, press New Search:

enter image description here

and type in your address.

  • Many (several) governments block messages and FaceTime, perhaps due to strong encryption, perhaps for other reasons. apple.stackexchange.com/questions/84844/… I doubt Apple would unlock or change those restrictions as it has to verify you aren’t in that region anymore and really can’t know who people are due to not tracking everything they could. – bmike Jun 21 '18 at 1:33
1

If nothing works out, You could jailbreak solution but it's just an option. This is just a suggestion. Jailbreaking has it's own set of pros and cons.

This issue can be fixed by updating the carrier.plist file. This requires your iPhone to be jailbroken on iOS 8.

  • Download CommCenter tweak from Cydia from repo apt.chinasnow.net
  • Install iFile from Cydia, now using iFile goto /var/mobile/Library/Carrier Bundle.bundle
  • Open carrier.plist file using property list viewer, click on the "+" to add a new entry
  • Type AllowsVoIP and set it type to boolean from string and create it
  • Turn on AllowsVoIP in the carrier.plist file and click done

After you've done that reboot the iPhone and Facetime app should appear. If not, reboot the iPhone once more and check over at Settings > General > Restrictions for FaceTime option.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .