5

I have been plagued with this problem for well over a year, and am hoping someone can shed some light on what is going on.

My setup is that I have a Macbook Pro that I use with a monitor while I'm at home, but I take it out of the house on a daily basis. While I'm at home, I backup the machine to a Western Digital MyBookLive network drive, using Time Machine. This arrangement worked just fine for the longest time. But about last year (sometime in Mountain Lion), I started having this issue where every time I'd come home and connect to my local WiFi, TimeMachine would kick in but soon gives me this message:

The backup disk image “/Volumes/TimeMachine/MyMBPro.sparsebundle” is already in use

I've looked far and wide for a proper solution to how to resolve this issue, but not found one.

The temporary solution (recommended by various websites) is always to restart the MyBookLive, either by disconnecting it's power or using it's website to restart, both of which are annoying and time-consuming options, especially on a daily basis. The Pondi website seems to suggest some network drive has been left connected, but that's not the case either.

There has to be a better way. Should I be disconnecting my machine before leaving the house to prevent this message when I reconnect? I've tried sleeping the computer before leaving, but that doesn't help. Neither does trying to "Skip this backup", which takes forever to finish up.

If someone has a good work-around or a suggestion I could try out, I'd really appreciate it.

  • Do you have multiple computers backing up to that same network drive? – daGUY Oct 15 '14 at 2:58
  • I have just one. My other Macbook Air doesn't have TimeMachine turned on. – Z S Oct 15 '14 at 3:09
  • FYI: I bought an Apple Time Capsule and haven't had this problem since. – Z S Aug 5 '15 at 13:50
2

Do you have access to you Western Digital MyBookLive via ssh ? Can you change some config files from it?

I believe Western Digital MyBookLive use netatalk for allow connect to it via afp protocol from mac os x. If it is true, when you abnormally disconnect from you MyBookLive netatalk wait by default 24 hours before dropping you connection see disconnect time parameter.

If you have access via ssh to you MyBookLive you can add "disconnect time = 1" parameter (one hour before dropping you connection) to the afp.conf file

And you can set "sleep time = 1" (Keep sleeping AFP sessions for number hours before disconnecting clients in sleep mode. Default is 10 hours.)

If you don't have access via ssh. I don't now. Maybe need check new firmware for you device, contact WD technical support on this issue.

1

I tried to remedy this problem from everything this and other sites said to do. It wasn't until the suggestion to go on the Western Digital MyBookLive to change parameters that I found it needed to be updated. I updated the firmware and the backups started automatically while I took a nap!

0

File in use Error is supposed to prevent a scenario where two apps compete to make changes to the same target, thus resulting in a corrupt file. Most files don't need to be locked, so you can piratically edit a .txt file both TextEdit and TextMate simultaneously. When Time Machine accesses a backup file (.sparebundle), it places a Hold on the file, so a user wouldn't, say use Finder to rename the .sparebundle at that moment.

The Hold should be removed as soon as TM finishes backing up. So:

lsof | grep -i MyMBPro

Run this command in THREE cases:

  1. When WiFi at home is normal, i,e. just finished up a backup.
  2. When the error message is present.
  3. When TM is doing the backup.

This will show if ANY process on your OS X is accessing the file.

For example, when I use TextMate to edit a file called notes.txt

lsof | grep -i notes.txt

I get:

TextMate  6539  username   37r     REG                1,7          4  804793 /Users/username/Documents/notes.txt

If the result is empty in case 1 and 2 but not 3, it means you OS is running correctly. The problem is with Western Digital.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .