1

When I got my iPhone 5, the Add Event button in Calendar was greyed out. I have tried adding events using Siri, and that doesn't work either. Why not?

1

I found it to be my password for iCloud. It dropped out after the update. I entered it back in and verified it and the calender came back online. Stupid update errors! enough to drive you bonkers!

0

I had the same problem, went into the calendar, tapped on "Calendars" in the bottom center, here there were two calendars listed - holidays, and birthdays. I pulled down on these items (like scrolling, the screen refreshed then showed 5 calendars. From some reason iCloud was not selected. I selected it and all the calendars listed became active.

I went back to the calendar view (by month) and am now able to add events.

BTW, none of the other options I have tried worked, only this method. Under general settings both my iCloud and Yahoo calendars were active, but under the actual program they were not. Don't waste your time in the general settings change it from the program.

0

When I had this problem, I went into year view, and there I was able to add an event. I changed beginning date to the right one and after creating this initial event, I was able to add new ones.

0

On iPhone 5, my wife's phone was showing no events. Went to Calendar, (bottom center) at top of next page page I found that the show all calendars was turned off. I changed it and all her events showed up.

-1

Make sure you have a Calendar set up in iOS, either an iCloud calendar (Settings -> iCloud) or another one (Settings -> Mail, Contacts, Calendars). If your only calendars are read-only, like Facebook Events and Birthdays, you won't be able to create events.

In iOS 7 and 8, you can check the calendars that have been set up by tapping "Calendars" at the bottom of the calendar view. If you don't see an iCloud calendar or another one you can edit, you'll need to create one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .