1

My Macbook Pro Running 10.8.5 isn't sleeping when left alone. System prefs has everything set up to sleep but it isn't working. I used the command pmset -g assertions in terminal and I get

Assertion status system-wide:
   PreventUserIdleDisplaySleep    0
   PreventSystemSleep             0
   PreventUserIdleSystemSleep     1
   InternalPreventDisplaySleep    0
   ExternalMedia                  0
   UserIsActive                   0
   ApplePushServiceTask           0
   BackgroundTask                 0

Listed by owning process:
  pid 386(Google Chrome): [0x000000010000021a] 22:54:00 NoIdleSleepAssertion named: "WebRTC has active PeerConnections." 
  pid 3791(helpd): [0x0000000c00000d34] 11:01:38 BackgroundTask named: 
"com.apple.helpd.sdmbuilding" 

So I'm assuming that this has to do with Google Chrome but I'm not sure what specifically. Anyone have any suggestions?

2

I resolved this problem. If anyone else runs into it in the future just go to chrome settings and then go to advanced settings and reset settings. It just brought me to default. Something in my settings was causing it. Honestly have no idea what it was.

0

The message "WebRTC has active PeerConnections"

could be a product of your Chrome settings.

Paste this "chrome://flags/" in your Chrome web address bar.

Find and disable the WebRTC.

  • I found it but its under Unavailable experiments it says Disable WebRTC Android Enabling this option prevents web applications from accessing the WebRTC API. #disable-webrtc Sorry, this experiment is not available on your platform. – InsomniacMac Oct 15 '14 at 0:51
  • hmmm? .. do you have Internet Sharing enabled or any Sharing ? – Ruskes Oct 15 '14 at 0:57
  • Nope, no sharing is enabled – InsomniacMac Oct 15 '14 at 0:58
  • It clearly says it is your Chrome doing it! which version is it ? – Ruskes Oct 15 '14 at 1:00
  • Version 38.0.2125.104 I made to sure to update it too just in case that was it – InsomniacMac Oct 15 '14 at 1:00
0

I had the same problem with some older versions of Chrome. They had a setting like "Allow background processes to run even when Chrome is closed". Every time Chrome updated to a new version I had to go to settings and uncheck this option, otherwise my MBP won't get to sleep by himself.

But this settings is not there any more since some versions of Chrome and have not noticed this behavior any more.

-1

I had similar problem on Win10 and my findings may be pertinent. I battled the problem where webRTC PeerConnections were preventing auto-sleep. In my experimentation, simply closing the tab that created the webRTC connections wasn't sufficient; I had to actually shut down chrome completely, i.e. exit all tabs. Then I found a more preferable work-around: instead of closing the tab that has webRTC connections, navigate that tab to a different web page or site which doesn't use webRTC. That will close out the webRTC connections and it isn't necessary to completely exit chrome. Note that this assumes that you've figured out which web site/page is causing the webRTC connections to be created. To do this, run "powercfg -requests" before and after opening tabs until you discover the culprit. For me it was the search results page on slickdeals.net website.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .