3

Summary: The fast/draft printing option is not available when connected over WiFi, but works with USB. (Editor Note: seems to effect many printers from both Canon an other manufacturers)

Specifically: I recently bought a Canon ix6850 printer to replace my Canon ix6500 (really the 6850 is just an updated version with built-in wifi). Now I've got this new 6850, if I connect to it over wifi I get the following the print setting. Note: draft is not an option.

screen shot of print options 1

But if I move my laptop next to the printer and connect via the usb cable I get the following. Any idea how I can enable draft when connecting over wifi?

screen shot of print options 2

4
+25

I've seen different features when someone is using the airprint driver (which automatically gets assigned to the printer when WiFied) compared to the 'normal' driver via USB. It says if it's airprint or not in system prefs>print&scan "Kind" Print & scan, Kind

You can choose what driver you want when you add the printer in the "use:" drop down. Try a couple. If as you say, the 6500 is the same but sans wifi then try the 6500 driver. I mean these are just first steps. I haven't even gotten into gutenprint or messing with ppd's to add features/paper sizes to drivers that don't officially support them. CUPS is some cool tech.

  • Thanks - the use dropdown is very handy, it allows me to print on draft now. – sam Oct 17 '14 at 12:59
1

Update and step-by-step directions:

On the latest versions of OSX (e.g. tested with High Sierra, 10.13.2) there is a seemingly handy option to add "nearby printer" which lists printers the OS can auto-locate. The problem is that this option defaults to using airprint and never gives the option to change the print driver with the "use" drop down.

To fix this (see also this Epson-focussed exchange on Apple Communities), reinstall the printer using the printer-specific driver:

  1. Open Printers & Scanners in System Preferences.
  2. Select the Printer with the troublesome airprint driver
  3. Press the minus sign, "-," at the bottom to remove the current printer
  4. Press the plus sign, "+," to add a new printer
  5. Don't select from the nearby list, but rather select "Other"
  6. The printer should still appear on the list in the resulting dialog. Selected it, but before pressing add, access the "Use" drop down to select the corresponding printer driver. If your printer type is not listed below AirPrint, see if it is listed under "Select Software..." If it is still not there, you might need to download an updated driver from your printer manufacturers website.
  7. Once you have the corresponding driver selected in "Use" press the "Add" button.

This should now use the manufacturer customized printer dialog including the option to select "Fast" for "Print Quality" under the "Quality and Media" option set.

0

Judging from the swapping of the words "Media & Quality" to "Quality & Media" in each screenshot, I'd say that when you use the printer with USB, your computer selects a different "draft-able" driver. When the printer is accessed over Wi-Fi, another driver is used, which prohibits Draft mode printing for some reason.

  • it seems that way some of the print options are different also, do you know is there a way to specify which driver the printer uses and when ? – sam Oct 16 '14 at 19:49
  • 1
    The command 'lpadmin' is your friend here. You can specify everything you need to about the printer. If you want to do the same thing using a friendlier interface, enable the CUPS web administration page. Enter 'sudo cupsctl WebInterface=yes' in Terminal, enter your password when required, then go to your web browser and navigate to the URL 'localhost:631/admin', press Add Printer, and follow the prompts. Your printer drivers are located in /Library/Printers/PPDs/. – Thomas Jones Oct 17 '14 at 3:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .